aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack-aio-deploy/README48
-rw-r--r--meta-openstack-aio-deploy/classes/hosts.bbclass17
-rw-r--r--meta-openstack-aio-deploy/conf/layer.conf10
-rw-r--r--meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend1
-rw-r--r--meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb (renamed from meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb)0
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-aio.bb29
6 files changed, 105 insertions, 0 deletions
diff --git a/meta-openstack-aio-deploy/README b/meta-openstack-aio-deploy/README
new file mode 100644
index 00000000..3603739f
--- /dev/null
+++ b/meta-openstack-aio-deploy/README
@@ -0,0 +1,48 @@
+meta-openstack-aio-deploy
+=============================
+
+This layer provides support configuring and deploying the recipes to create an
+all-in-one compute/controller node.
+
+Dependencies
+------------
+
+This layer depends on:
+
+URI: git://github.com/openembedded/oe-core.git
+branch: master
+revision: HEAD
+prio: default
+
+URI: git://github.com/openembedded/meta-oe.git
+patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
+revision: HEAD
+layers: meta-oe
+ meta-networking
+ meta-ruby
+
+URI: git://git.yoctoproject.org/meta-virtualization
+branch: master
+revision: head
+
+meta-openstack
+branch: master
+revision: head
+
+Maintenance
+-----------
+
+Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
+
+When sending single patches, please using something like:
+'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
+
+Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
+
+License
+-------
+
+All metadata is MIT licensed unless otherwise stated. Source code included
+in tree for individual recipes is under the LICENSE stated in each recipe
+(.bb file) unless otherwise stated.
+
diff --git a/meta-openstack-aio-deploy/classes/hosts.bbclass b/meta-openstack-aio-deploy/classes/hosts.bbclass
new file mode 100644
index 00000000..82c9eb7f
--- /dev/null
+++ b/meta-openstack-aio-deploy/classes/hosts.bbclass
@@ -0,0 +1,17 @@
+#
+# all-in-one hosts file
+#
+# The aio rootfs combines the functionality of the compute and
+# the controller in one node.
+#
+# The aio rootfs adds another hostname aio, since we need
+# ths hostname compute and controller for the system's functionality,
+# we defined compute and controller in this file as well.
+#
+COMPUTE_IP ?= "${CONTROLLER_IP}"
+COMPUTE_HOST ?= "compute"
+CONTROLLER_IP ?= "128.224.149.173"
+CONTROLLER_HOST ?= "controller"
+MY_IP ?= "${CONTROLLER_IP}"
+MY_HOST ?= "${CONTROLLER_HOST}"
+DB_DATADIR ?= "/etc/postgresql"
diff --git a/meta-openstack-aio-deploy/conf/layer.conf b/meta-openstack-aio-deploy/conf/layer.conf
new file mode 100644
index 00000000..d1d1f641
--- /dev/null
+++ b/meta-openstack-aio-deploy/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend ${LAYERDIR}/classes/*.bbclass"
+
+BBFILE_COLLECTIONS += "openstack-aio-deploy-layer"
+BBFILE_PATTERN_openstack-aio-deploy-layer := "^${LAYERDIR}/"
+BBFILE_PRIORITY_openstack-aio-deploy-layer = "6"
+
diff --git a/meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend b/meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend
new file mode 100644
index 00000000..28b44ec4
--- /dev/null
+++ b/meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend
@@ -0,0 +1 @@
+inherit hosts
diff --git a/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb b/meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb
index 459628a6..459628a6 100644
--- a/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb
+++ b/meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb
diff --git a/meta-openstack/recipes-extended/images/openstack-image-aio.bb b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
new file mode 100644
index 00000000..57f42495
--- /dev/null
+++ b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Openstack all-in-one node image"
+LICENSE = "MIT"
+
+OPENSTACK_CONTROLLER_EXTRA_INSTALL ?= ""
+OPENSTACK_COMPUTE_EXTRA_INSTALL ?= ""
+OPENSTACK_AIO_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = " \
+ ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
+ ${CORE_IMAGE_BASE_INSTALL} \
+ packagegroup-core-full-cmdline \
+ packagegroup-cloud-compute \
+ packagegroup-cloud-controller \
+ packagegroup-cloud-network \
+ packagegroup-cloud-debug \
+ packagegroup-cloud-extras \
+ ${OPENSTACK_CONTROLLER_EXTRA_INSTALL} \
+ ${OPENSTACK_COMPUTE_EXTRA_INSTALL} \
+ ${OPENSTACK_AIO_EXTRA_INSTALL} \
+ "
+
+IMAGE_FEATURES += "ssh-server-openssh"
+
+inherit core-image
+inherit openstack-base
+
+# check for 5G of free space, so we use 5G as a starting point.
+IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 5000000"
+