aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-support/memcached/memcached/configure.patch13
-rw-r--r--meta-openstack/recipes-support/memcached/memcached_1.4.17.bb24
2 files changed, 22 insertions, 15 deletions
diff --git a/meta-openstack/recipes-support/memcached/memcached/configure.patch b/meta-openstack/recipes-support/memcached/memcached/configure.patch
new file mode 100644
index 00000000..7001a0ed
--- /dev/null
+++ b/meta-openstack/recipes-support/memcached/memcached/configure.patch
@@ -0,0 +1,13 @@
+Index: memcached-1.4.17/configure.ac
+===================================================================
+--- memcached-1.4.17.orig/configure.ac 2013-12-20 21:44:49.000000000 +0000
++++ memcached-1.4.17/configure.ac 2014-07-18 07:17:00.593499483 +0000
+@@ -4,7 +4,7 @@
+ AC_INIT(memcached, VERSION_NUMBER, memcached@googlegroups.com)
+ AC_CANONICAL_SYSTEM
+ AC_CONFIG_SRCDIR(memcached.c)
+-AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
++AM_INIT_AUTOMAKE([foreign])
+ AM_CONFIG_HEADER(config.h)
+
+ AC_PROG_CC
diff --git a/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb b/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
index 43c826fc..5d37df08 100644
--- a/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
+++ b/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
@@ -1,12 +1,5 @@
SUMMARY = "A high-performance memory object caching system"
DESCRIPTION = "\
- Danga Interactive developed memcached to enhance the speed of LiveJournal.com, \
- a site which was already doing 20 million+ dynamic page views per day for 1 \
- million users with a bunch of webservers and a bunch of database servers. \
- memcached dropped the database load to almost nothing, yielding faster page \
- load times for users, better resource utilization, and faster access to the \
- databases on a memcache miss. \
- . \
memcached optimizes specific high-load serving applications that are designed \
to take advantage of its versatile no-locking memory access system. Clients \
are available in several different programming languages, to suit the needs \
@@ -14,17 +7,18 @@ DESCRIPTION = "\
apps to avoid storing large chunks of data in Apache memory, and to share \
this burden across several machines."
-HOMEPAGE = "http://www.danga.com/memcached/"
-LICENSE = "BSD"
+HOMEPAGE = "http://memcached.org/"
+LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
-inherit autotools autotools-brokensep
+inherit autotools
DEPENDS += "libevent"
RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader perl-module-tie-hash"
-SRC_URI = "http://www.memcached.org/files/${PN}-${PV}.tar.gz"
+SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
+ file://configure.patch"
SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
@@ -43,8 +37,8 @@ INITSCRIPT_NAME = "memcached"
INITSCRIPT_PARAMS = "defaults"
do_install_append() {
- install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
- mkdir -p ${D}/usr/share/memcached/scripts
- install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
- install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
+ install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
+ mkdir -p ${D}/usr/share/memcached/scripts
+ install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
+ install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
}