aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch34
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch b/meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch
new file mode 100644
index 00000000..ba09f7ba
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch
@@ -0,0 +1,34 @@
+Binary files git.orig/neutron/api/v2/.attributes.py.swp and git/neutron/api/v2/.attributes.py.swp differ
+diff -uNr git.orig/neutron/api/v2/attributes.py git/neutron/api/v2/attributes.py
+--- git.orig/neutron/api/v2/attributes.py 2014-06-23 11:27:07.498653115 -0400
++++ git/neutron/api/v2/attributes.py 2014-06-23 11:31:18.467897605 -0400
+@@ -311,7 +311,10 @@
+
+ def _validate_uuid(data, valid_values=None):
+ if not uuidutils.is_uuid_like(data):
+- msg = _("'%s' is not a valid UUID") % data
++ if data != data.rstrip():
++ msg = _("'%s' is not a valid UUID: trailing whitespace?") % data
++ else:
++ msg = _("'%s' is not a valid UUID") % data
+ LOG.debug(msg)
+ return msg
+
+Binary files git.orig/neutron/plugins/cisco/n1kv/.n1kv_neutron_plugin.py.swp and git/neutron/plugins/cisco/n1kv/.n1kv_neutron_plugin.py.swp differ
+diff -uNr git.orig/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py git/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py
+--- git.orig/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py 2014-06-23 11:27:07.510653175 -0400
++++ git/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py 2014-06-23 11:34:04.968723238 -0400
+@@ -642,8 +642,11 @@
+ raise q_exc.InvalidInput(error_message=msg)
+ pair_list.append((segment, dot1qtag))
+ else:
+- LOG.debug(_('%s is not a valid uuid'), segment)
+- msg = _("'%s' is not a valid UUID") % segment
++ if segment != segment.rstrip():
++ msg = _("'%s' is not a valid UUID: trailing whitespace?") % segment
++ else:
++ msg = _("'%s' is not a valid UUID") % segment
++ LOG.debug(msg)
+ raise q_exc.InvalidInput(error_message=msg)
+ return pair_list
+
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 2a581ca2..3973b63b 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -16,6 +16,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
file://dhcp_agent.ini \
file://metadata_agent.ini \
file://neutron-dhcp-agent-netns-cleanup.cron \
+ file://uuid_wscheck.patch \
"
SRCREV="a8417d78c2675a2ceb5dbfcee70948a88d69e747"
PV="2013.2.3+git${SRCPV}"