aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack-controller-deploy/README48
-rw-r--r--meta-openstack-controller-deploy/classes/controller.bbclass2
-rw-r--r--meta-openstack-controller-deploy/conf/layer.conf9
-rw-r--r--meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend1
4 files changed, 60 insertions, 0 deletions
diff --git a/meta-openstack-controller-deploy/README b/meta-openstack-controller-deploy/README
new file mode 100644
index 00000000..0e31c177
--- /dev/null
+++ b/meta-openstack-controller-deploy/README
@@ -0,0 +1,48 @@
+meta-openstack-controller-deploy
+=============================
+
+This layer provides support configuring and deploying the recipes to create a
+controller node.
+
+Dependencies
+------------
+
+This layer depends on:
+
+URI: git://github.com/openembedded/oe-core.git
+branch: master
+revision: HEAD
+prio: default
+
+URI: git://github.com/openembedded/meta-oe.git
+patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
+revision: HEAD
+layers: meta-oe
+ meta-networking
+ meta-ruby
+
+URI: git://git.yoctoproject.org/meta-virtualization
+branch: master
+revision: head
+
+meta-openstack
+branch: master
+revision: head
+
+Maintenance
+-----------
+
+Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
+
+When sending single patches, please using something like:
+'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
+
+Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
+
+License
+-------
+
+All metadata is MIT licensed unless otherwise stated. Source code included
+in tree for individual recipes is under the LICENSE stated in each recipe
+(.bb file) unless otherwise stated.
+
diff --git a/meta-openstack-controller-deploy/classes/controller.bbclass b/meta-openstack-controller-deploy/classes/controller.bbclass
new file mode 100644
index 00000000..1db2714b
--- /dev/null
+++ b/meta-openstack-controller-deploy/classes/controller.bbclass
@@ -0,0 +1,2 @@
+CONTROLLER_IP = "0.0.0.0"
+CONTROLLER_HOST = "localhost"
diff --git a/meta-openstack-controller-deploy/conf/layer.conf b/meta-openstack-controller-deploy/conf/layer.conf
new file mode 100644
index 00000000..de8f4352
--- /dev/null
+++ b/meta-openstack-controller-deploy/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "openstack-controller-deploy-layer"
+BBFILE_PATTERN_openstack-controller-deploy-layer := "^${LAYERDIR}/"
+BBFILE_PRIORITY_openstack-controller-deploy-layer = "6"
diff --git a/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend b/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
new file mode 100644
index 00000000..d463e541
--- /dev/null
+++ b/meta-openstack-controller-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
@@ -0,0 +1 @@
+inherit controller