aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone/identity.sh2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb11
2 files changed, 10 insertions, 3 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone/identity.sh b/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
index db222e15..df6fd1c5 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
+++ b/meta-openstack/recipes-devtools/python/python-keystone/identity.sh
@@ -14,7 +14,7 @@ MYSQL_HOST=localhost
MYSQL_PASSWORD=password
#
KEYSTONE_REGION=RegionOne
-KEYSTONE_HOST=localhost
+KEYSTONE_HOST=%CONTROLLER_IP%
# Shortcut function to get a newly generated ID
function get_field() {
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
index bc303334..e1245837 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "e097170ebb1cf22de50f2d5ab2216a5116ffe0934720dbad8b02d61c37
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit setuptools update-rc.d identity
+inherit setuptools update-rc.d identity hosts
SERVICE_TOKEN = "password"
@@ -33,6 +33,11 @@ do_install_append() {
sed -e "s:%DB_USER%:${DB_USER}:g" -i ${WORKDIR}/keystone.conf
sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${WORKDIR}/keystone.conf
+ sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${WORKDIR}/keystone.conf
+ sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${WORKDIR}/identity.sh
+
+ install -d ${D}${localstatedir}/log/${SRCNAME}
+
install -m 600 ${WORKDIR}/keystone.conf ${KEYSTONE_CONF_DIR}/
install -m 600 ${WORKDIR}/identity.sh ${KEYSTONE_CONF_DIR}/
install -m 600 ${WORKDIR}/openrc ${KEYSTONE_CONF_DIR}/
@@ -82,7 +87,9 @@ FILES_${PN} = "${libdir}/*"
FILES_${SRCNAME} = "${bindir}/* \
${sysconfdir}/${SRCNAME}/* \
- ${sysconfdir}/init.d/* "
+ ${sysconfdir}/init.d/* \
+ ${localstatedir}/* \
+ "
RDEPENDS_${PN} += "python-pam \
python-webob \