aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch32
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb5
2 files changed, 35 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch b/meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch
new file mode 100644
index 00000000..38d5343c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cliff/0001-Fix-object-has-no-attribute-debug-error.patch
@@ -0,0 +1,32 @@
+From f2c997161df01579cabf312a694289a1a83ae6ca Mon Sep 17 00:00:00 2001
+From: TerryHowe <terrylhowe@gmail.com>
+Date: Thu, 28 May 2015 07:55:11 -0600
+Subject: [PATCH] Fix object has no attribute debug error
+
+When print_help_if_requested is called, if there is an error,
+"object has no attribute 'debug'" gets printed out. This is
+because the parser is passed in to the command rather than the
+parsed arguments.
+
+Change-Id: I1863421eff82b3f493d276432369ada9f783b165
+Partial-Bug: #1459519
+---
+ cliff/app.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cliff/app.py b/cliff/app.py
+index e052571..a41386a 100644
+--- a/cliff/app.py
++++ b/cliff/app.py
+@@ -198,7 +198,7 @@ class App(object):
+ def print_help_if_requested(self):
+ if self.deferred_help and self.options.deferred_help:
+ action = HelpAction(None, None, default=self)
+- action(self.parser, self.parser, None, None)
++ action(self.parser, self.options, None, None)
+
+ def run(self, argv):
+ """Equivalent to the main program for the application.
+--
+2.1.0
+
diff --git a/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb b/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb
index e107a28b..e7e1f7ed 100644
--- a/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-cliff_1.10.0.bb
@@ -4,10 +4,11 @@ SECTION = "devel/python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PR = "r0"
SRCNAME = "cliff"
-SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://0001-Fix-object-has-no-attribute-debug-error.patch \
+ "
SRC_URI[md5sum] = "8f3f67d57bf5a2541efeedcea1aa64ab"
SRC_URI[sha256sum] = "209882e199fdf98aeed0db44b922aa688e5a66d81c45148a5743804f9aa680e1"