aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-testresources.inc10
-rw-r--r--meta-openstack/recipes-devtools/python/python-testresources_0.2.7.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb2
3 files changed, 14 insertions, 10 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testresources.inc b/meta-openstack/recipes-devtools/python/python-testresources.inc
new file mode 100644
index 00000000..67ad6c4d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-testresources.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Testresources, a pyunit extension for managing expensive test resources"
+HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README;md5=038679cd2cf27bb2acc70257bfee0f41"
+
+SRC_URI[md5sum] = "db2e774be2a6f5754cbbf4c537f823d0"
+SRC_URI[sha256sum] = "ad0a117383dd463827b199eaa92829b4d6a3147fbd97459820df53bae81d7231"
+
+inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python-testresources_0.2.7.bb b/meta-openstack/recipes-devtools/python/python-testresources_0.2.7.bb
index fe8dbb1e..d939405f 100644
--- a/meta-openstack/recipes-devtools/python/python-testresources_0.2.7.bb
+++ b/meta-openstack/recipes-devtools/python/python-testresources_0.2.7.bb
@@ -1,10 +1,2 @@
-DESCRIPTION = "Testresources, a pyunit extension for managing expensive test resources"
-HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://README;md5=038679cd2cf27bb2acc70257bfee0f41"
-
-SRC_URI[md5sum] = "db2e774be2a6f5754cbbf4c537f823d0"
-SRC_URI[sha256sum] = "ad0a117383dd463827b199eaa92829b4d6a3147fbd97459820df53bae81d7231"
-
-inherit setuptools pypi
+require python-testresources.inc
+inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb b/meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb
new file mode 100644
index 00000000..79a535c7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb
@@ -0,0 +1,2 @@
+require python-testresources.inc
+inherit setuptools3