aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-amd-bsp/conf/machine/e3000.conf2
-rw-r--r--meta-amd-bsp/conf/machine/r1000.conf2
-rw-r--r--meta-amd-bsp/conf/machine/v1000.conf2
-rw-r--r--meta-amd-distro/conf/layer.conf5
-rw-r--r--meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend22
-rw-r--r--meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending14
-rw-r--r--meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending.service16
7 files changed, 59 insertions, 4 deletions
diff --git a/meta-amd-bsp/conf/machine/e3000.conf b/meta-amd-bsp/conf/machine/e3000.conf
index e37cd9b8..7ef6462b 100644
--- a/meta-amd-bsp/conf/machine/e3000.conf
+++ b/meta-amd-bsp/conf/machine/e3000.conf
@@ -20,7 +20,7 @@ MACHINE_FEATURES_remove = "alsa"
MACHINE_EXTRA_RRECOMMENDS_remove = " rtc-test alsa-utils"
# Setup a getty on all serial ports
-SERIAL_CONSOLES ?= "115200;ttyS4 115200;ttyS5"
+SERIAL_CONSOLES = "115200;ttyS4 115200;ttyS5"
# Enable the kernel console on ttyS4/COM0
KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
diff --git a/meta-amd-bsp/conf/machine/r1000.conf b/meta-amd-bsp/conf/machine/r1000.conf
index f8bdf214..c06ef728 100644
--- a/meta-amd-bsp/conf/machine/r1000.conf
+++ b/meta-amd-bsp/conf/machine/r1000.conf
@@ -36,7 +36,7 @@ MACHINE_EXTRA_RRECOMMENDS += "amdgpu-firmware grub-efi"
MACHINE_EXTRA_RRECOMMENDS_remove = "rtc-test smbus-test grub"
# Setup a getty on all serial ports
-SERIAL_CONSOLES ?= "115200;ttyS4 115200;ttyS5"
+SERIAL_CONSOLES = "115200;ttyS4 115200;ttyS5"
# Enable the kernel console on ttyS4/USB0 as well
KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
diff --git a/meta-amd-bsp/conf/machine/v1000.conf b/meta-amd-bsp/conf/machine/v1000.conf
index 811d885f..8b323063 100644
--- a/meta-amd-bsp/conf/machine/v1000.conf
+++ b/meta-amd-bsp/conf/machine/v1000.conf
@@ -35,7 +35,7 @@ MACHINE_EXTRA_RRECOMMENDS += "amdgpu-firmware grub-efi"
MACHINE_EXTRA_RRECOMMENDS_remove = "rtc-test smbus-test grub"
# Setup a getty on all serial ports
-SERIAL_CONSOLES ?= "115200;ttyS4 115200;ttyS5"
+SERIAL_CONSOLES = "115200;ttyS4 115200;ttyS5"
# Enable the kernel console on ttyS4/USB0 as well
KERNEL_SERIAL_CONSOLE ?= "console=ttyS4,115200n8"
diff --git a/meta-amd-distro/conf/layer.conf b/meta-amd-distro/conf/layer.conf
index 729c3abd..b46a08ea 100644
--- a/meta-amd-distro/conf/layer.conf
+++ b/meta-amd-distro/conf/layer.conf
@@ -1,8 +1,11 @@
# We have a conf and classes directory, add to BBPATH
BBPATH .= ":${LAYERDIR}"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "amd-distro"
-BBFILE_PATTERN_amd-distro := "^${LAYERDIR}/"
+BBFILE_PATTERN_amd-distro = "^${LAYERDIR}/"
BBFILE_PRIORITY_amd-distro = "12"
LAYERSERIES_COMPAT_amd-distro = "warrior"
diff --git a/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend b/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend
new file mode 100644
index 00000000..099292ab
--- /dev/null
+++ b/meta-amd-distro/recipes-devtools/dpkg/dpkg_%.bbappend
@@ -0,0 +1,22 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+inherit systemd
+
+SYSTEMD_SERVICE_${PN} = "dpkg-configure-pending.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+SRC_URI += " \
+ file://dpkg-configure-pending.service \
+ file://dpkg-configure-pending \
+"
+
+do_install_append () {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/dpkg-configure-pending.service ${D}${systemd_unitdir}/system/
+ install -m 755 ${WORKDIR}/dpkg-configure-pending ${D}${sbindir}/dpkg-configure-pending
+}
+
+FILES_${PN} += " \
+ ${systemd_unitdir}/system/dpkg-configure-pending.service \
+ ${sbindir}/dpkg-configure-pending \
+"
diff --git a/meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending b/meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending
new file mode 100644
index 00000000..ba3bf025
--- /dev/null
+++ b/meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+[ -e /etc/default/postinst ] && . /etc/default/postinst
+if [ "$POSTINST_LOGGING" = "1" ]; then
+ append_log="| tee -a $LOGFILE"
+fi
+
+[ "$POSTINST_LOGGING" = "1" ] && eval echo "Attempting to reconfigure packages on first boot that had failed postinsts..." ${append_log}
+
+dpkg --configure --pending | tee -a $LOGFILE
+
+if [ -n "`which update-rc.d`" ]; then
+ update-rc.d -f dpkg-configure-pending remove | tee -a $LOGFILE
+fi
diff --git a/meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending.service b/meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending.service
new file mode 100644
index 00000000..57d582f5
--- /dev/null
+++ b/meta-amd-distro/recipes-devtools/dpkg/files/dpkg-configure-pending.service
@@ -0,0 +1,16 @@
+[Unit]
+Description="Configure pkgs with failed postinsts that Sato GUI depends on."
+DefaultDependencies=no
+After=sysinit.target
+Before=multi-user.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/sbin/dpkg-configure-pending
+ExecStartPost=/bin/systemctl --no-reload disable dpkg-configure-pending.service
+RemainAfterExit=No
+TimeoutSec=0
+User=root
+
+[Install]
+WantedBy=graphical.target