aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_8b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_8b.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_8b.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8b.bb b/meta/recipes-core/jpeg/jpeg_8b.bb
index 8e2c24dd21..78fabf1efd 100644
--- a/meta/recipes-core/jpeg/jpeg_8b.bb
+++ b/meta/recipes-core/jpeg/jpeg_8b.bb
@@ -14,7 +14,7 @@ PRIORITY = "required"
DEPENDS = "libtool-cross"
DEPENDS_virtclass-native = "libtool-native"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
file://debian-libjpeg7_7-1.diff;patch=1"
@@ -45,3 +45,14 @@ DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs fo
FILES_jpeg-tools = "${bindir}/*"
BBCLASSEXTEND = "native"
+
+pkg_postinst_${PN}_poky-lsb () {
+ if [ "$D" = "" ]; then
+ if [ ! -e ${libdir}/libjpeg.so.62 ]; then
+ JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
+ ln -sf `basename $JPEG` ${libdir}/libjpeg.so.62
+ fi
+ else
+ exit 1
+ fi
+}