aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/poky-ref-manual
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2011-03-16 22:50:06 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-18 23:33:08 +0000
commit62432306752c9863780a7addf60b06f8035eddd4 (patch)
tree6a2b8e975a427b2c7810c69e2a76637ddedaf5a1 /documentation/poky-ref-manual
parentc0298557bad2e431f6dc87b6fda061cab561e14c (diff)
downloadpoky-62432306752c9863780a7addf60b06f8035eddd4.tar.gz
poky-62432306752c9863780a7addf60b06f8035eddd4.tar.bz2
poky-62432306752c9863780a7addf60b06f8035eddd4.zip
- documentation/poky-ref-manual: Notes added for non-GPLv3 builds
[BUGID# 873] - Added a note in the Images Appendix indicating that building an image without GPLv3 components is only supported for base and minimal images. Also put the two changes you have to do to the local.conf file for the build. Added a note in the second chapter in the section on building images. The note indicates the same as in the appendix but does not go into the local.conf file detail. (From OE-Core rev: c7960a2e820d7ddb8649ab0b27b3f04843f7af0d) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/poky-ref-manual')
-rw-r--r--documentation/poky-ref-manual/ref-images.xml12
-rw-r--r--documentation/poky-ref-manual/usingpoky.xml7
2 files changed, 18 insertions, 1 deletions
diff --git a/documentation/poky-ref-manual/ref-images.xml b/documentation/poky-ref-manual/ref-images.xml
index 9477883373..03cc624504 100644
--- a/documentation/poky-ref-manual/ref-images.xml
+++ b/documentation/poky-ref-manual/ref-images.xml
@@ -13,6 +13,18 @@
Images are listed below along with details of what they contain:
</para>
+ <note>
+ Building an image without GNU Public License Version 3 (GPLv3) components is
+ only supported for minimal and base images.
+ Furthermore, if you are going to build an image using non-GPLv3 components,
+ you must make the following changes in the <filename>local.conf</filename> file
+ before using the BitBake command to build the minimal or base image:
+ <literallayout class='monospaced'>
+ 1. Comment out the IMAGE_EXTRA_FEATURES line
+ 2. Set INCOMPATIBLE_LICENSE = "GPLv3"
+ </literallayout>
+ </note>
+
<itemizedlist>
<listitem>
<para>
diff --git a/documentation/poky-ref-manual/usingpoky.xml b/documentation/poky-ref-manual/usingpoky.xml
index 75932665a3..92e3ed5a46 100644
--- a/documentation/poky-ref-manual/usingpoky.xml
+++ b/documentation/poky-ref-manual/usingpoky.xml
@@ -151,13 +151,18 @@
</para>
<para>
The target is the name of the recipe you want to build.
- Common targets are the images in <filename>meta/recipes-core/images</filename>),
+ Common targets are the images in <filename>meta/recipes-core/images</filename>,
<filename>/meta/recipes-sato/images</filename>, etc.
Or, the target can be the name of a recipe for a specific piece of software such as
<application>busybox</application>.
For more details about the standard images available, see the
<link linkend="ref-images">'Reference: Images'</link> appendix.
</para>
+ <note>
+ Building an image without GNU Public License Version 3 (GPLv3) components is
+ only supported for minimal and base images.
+ See <link linkend='ref-images'>'Reference: Images'</link> for more information.
+ </note>
</section>
<section id='usingpoky-install'>