summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@microsoft.com>2021-04-12 13:44:56 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-15 20:18:57 +0100
commit83960012388c9b08e293ccdb8e4a4ef95f14887a (patch)
tree6abfa939bf14439d50e6b32fda38968d1883ac97
parentb56736ae7699060d4925f22d4129b1e8b9c20328 (diff)
downloadpoky-83960012388c9b08e293ccdb8e4a4ef95f14887a.tar.gz
poky-83960012388c9b08e293ccdb8e4a4ef95f14887a.tar.bz2
poky-83960012388c9b08e293ccdb8e4a4ef95f14887a.zip
Use variables for minimum host versions and bump Python to 3.6
Minimum Git, tar, Python and gcc versions are specified in quite a few different places. Let's add some variables for these so there's no chance of missing one if they're updated in future. Additionally, for hardknott the minimum Python version is 3.6 so set that as the value for Python. (From yocto-docs rev: 9a802bc4bb0438c2540f360a08c7787caf64408a) Signed-off-by: Paul Eggleton <paul.eggleton@microsoft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--documentation/brief-yoctoprojectqs/index.rst8
-rw-r--r--documentation/dev-manual/start.rst8
-rw-r--r--documentation/poky.yaml4
-rw-r--r--documentation/ref-manual/faq.rst2
-rw-r--r--documentation/ref-manual/system-requirements.rst8
5 files changed, 17 insertions, 13 deletions
diff --git a/documentation/brief-yoctoprojectqs/index.rst b/documentation/brief-yoctoprojectqs/index.rst
index 7bba47ea9c..974ae5ebca 100644
--- a/documentation/brief-yoctoprojectqs/index.rst
+++ b/documentation/brief-yoctoprojectqs/index.rst
@@ -60,10 +60,10 @@ following requirements:
-
- - Git 1.8.3.1 or greater
- - tar 1.28 or greater
- - Python 3.5.0 or greater.
- - gcc 5.0 or greater.
+ - Git &MIN_GIT_VERSION; or greater
+ - tar &MIN_TAR_VERSION; or greater
+ - Python &MIN_PYTHON_VERSION; or greater.
+ - gcc &MIN_GCC_VERSION; or greater.
If your build host does not meet any of these three listed version
requirements, you can take steps to prepare the system so that you
diff --git a/documentation/dev-manual/start.rst b/documentation/dev-manual/start.rst
index 39036183b0..84abf4c51f 100644
--- a/documentation/dev-manual/start.rst
+++ b/documentation/dev-manual/start.rst
@@ -314,13 +314,13 @@ Project Build Host:
should be able to run on any modern distribution that has the
following versions for Git, tar, Python and gcc.
- - Git 1.8.3.1 or greater
+ - Git &MIN_GIT_VERSION; or greater
- - tar 1.28 or greater
+ - tar &MIN_TAR_VERSION; or greater
- - Python 3.5.0 or greater.
+ - Python &MIN_PYTHON_VERSION; or greater.
- - gcc 5.0 or greater.
+ - gcc &MIN_GCC_VERSION; or greater.
If your build host does not meet any of these three listed version
requirements, you can take steps to prepare the system so that you
diff --git a/documentation/poky.yaml b/documentation/poky.yaml
index e0cf0b3ba4..8ccb359e0f 100644
--- a/documentation/poky.yaml
+++ b/documentation/poky.yaml
@@ -40,3 +40,7 @@ CENTOS8_HOST_PACKAGES_ESSENTIAL : "-y epel-release
python3-GitPython python3-jinja2 python3-pexpect xz which SDL-devel xterm \
rpcgen mesa-libGL-devel"
PIP3_HOST_PACKAGES_DOC : "$ sudo pip3 install sphinx sphinx_rtd_theme pyyaml"
+MIN_PYTHON_VERSION : "3.6.0"
+MIN_TAR_VERSION : "1.28"
+MIN_GIT_VERSION : "1.8.3.1"
+MIN_GCC_VERSION : "5.0"
diff --git a/documentation/ref-manual/faq.rst b/documentation/ref-manual/faq.rst
index 3b65588caa..64fdfdf756 100644
--- a/documentation/ref-manual/faq.rst
+++ b/documentation/ref-manual/faq.rst
@@ -16,7 +16,7 @@ first before being pulled back into Poky. This practice benefits both
projects immediately.
**Q:** My development system does not meet the required Git, tar, and
-Python versions. In particular, I do not have Python 3.5.0 or greater.
+Python versions. In particular, I do not have Python &MIN_PYTHON_VERSION; or greater.
Can I still use the Yocto Project?
**A:** You can get the required tools on your host development system a
diff --git a/documentation/ref-manual/system-requirements.rst b/documentation/ref-manual/system-requirements.rst
index 6edfa1a865..dc619cece3 100644
--- a/documentation/ref-manual/system-requirements.rst
+++ b/documentation/ref-manual/system-requirements.rst
@@ -256,11 +256,11 @@ Required Git, tar, Python and gcc Versions
In order to use the build system, your host development system must meet
the following version requirements for Git, tar, and Python:
-- Git 1.8.3.1 or greater
+- Git &MIN_GIT_VERSION; or greater
-- tar 1.28 or greater
+- tar &MIN_TAR_VERSION; or greater
-- Python 3.5.0 or greater
+- Python &MIN_PYTHON_VERSION; or greater
If your host development system does not meet all these requirements,
you can resolve this by installing a ``buildtools`` tarball that
@@ -270,7 +270,7 @@ a pre-built tarball or use BitBake to build the tarball.
In addition, your host development system must meet the following
version requirement for gcc:
-- gcc 5.0 or greater
+- gcc &MIN_GCC_VERSION; or greater
If your host development system does not meet this requirement, you can
resolve this by installing a ``buildtools-extended`` tarball that