aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc7
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb8
2 files changed, 10 insertions, 5 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc
index c97a4a4a..90e0ab25 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc
@@ -2,9 +2,14 @@ require recipes-bsp/u-boot/u-boot.inc
DEPENDS += "bc-native dtc-native"
+XILINX_RELEASE_VERSION ?= ""
+UBOOT_VERSION_EXTENSION ?= "-xilinx-${XILINX_RELEASE_VERSION}"
+PV = "${UBOOT_VERSION}${UBOOT_VERSION_EXTENSION}+git${SRCPV}"
+
UBOOTURI ?= "git://github.com/Xilinx/u-boot-xlnx.git;protocol=https"
-UBRANCH ?= "master"
+UBRANCH ?= ""
UBRANCHARG = "${@['nobranch=1', 'branch=${UBRANCH}'][d.getVar('UBRANCH', True) != '']}"
+
SRC_URI = "${UBOOTURI};${UBRANCHARG}"
S = "${WORKDIR}/git"
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
index c10564f4..b7817c94 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
@@ -1,9 +1,9 @@
-include u-boot-xlnx.inc
-include u-boot-spl-zynq-init.inc
-
+UBOOT_VERSION = "v2017.01"
XILINX_RELEASE_VERSION = "v2017.3"
SRCREV ?= "da811c4511ef9caeb95f9a22fe49d38bd8e56ded"
-PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
+
+include u-boot-xlnx.inc
+include u-boot-spl-zynq-init.inc
SRC_URI_append = " \
file://arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch \