aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-bsp/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc2
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2018.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc b/meta-xilinx-bsp/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
index a83bdebe..02bbc732 100644
--- a/meta-xilinx-bsp/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
+++ b/meta-xilinx-bsp/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc
@@ -60,7 +60,7 @@ do_deploy() {
# Get the entry point address from the elf.
BL31_BASE_ADDR=$(${READELF} -h ${OUTPUT_DIR}/bl31/bl31.elf | egrep -m 1 -i "entry point.*?0x" | sed -r 's/.*?(0x.*?)/\1/g')
- mkimage -A arm64 -O linux -T kernel -C none \
+ mkimage -A arm64 -O arm-trusted-firmware -T kernel -C none \
-a $BL31_BASE_ADDR -e $BL31_BASE_ADDR \
-d ${OUTPUT_DIR}/bl31.bin ${DEPLOYDIR}/${ATF_BASE_NAME}.ub
ln -sf ${ATF_BASE_NAME}.ub ${DEPLOYDIR}/${PN}.ub
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2018.1.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2018.1.bb
index 0b5b085a..6388cf33 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2018.1.bb
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2018.1.bb
@@ -3,7 +3,7 @@ XILINX_RELEASE_VERSION = "v2018.1"
UBRANCH ?= "master"
-SRCREV ?= "1c81b42a326e5b74a5b79e55de9c52b5781b7a8a"
+SRCREV ?= "949e5cb9a736bac32ea8886e3953da55bdd30754"
include u-boot-xlnx.inc
include u-boot-spl-zynq-init.inc