aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/ipxe/ipxe_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ipxe/ipxe_git.bb')
-rw-r--r--recipes-extended/ipxe/ipxe_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-extended/ipxe/ipxe_git.bb b/recipes-extended/ipxe/ipxe_git.bb
index 448087e5..43c8f0ed 100644
--- a/recipes-extended/ipxe/ipxe_git.bb
+++ b/recipes-extended/ipxe/ipxe_git.bb
@@ -27,12 +27,16 @@ EXTRA_OEMAKE = " \
ISOLINUX_BIN="${STAGING_DIR_TARGET}/usr/share/syslinux/isolinux.bin" \
CROSS_COMPILE="${TARGET_PREFIX}" \
EXTRA_HOST_CFLAGS="${BUILD_CFLAGS}" \
- EXTRA_HOST_LDFLAGS="${BUILD_LDFLAGS}""
+ EXTRA_HOST_LDFLAGS="${BUILD_LDFLAGS}" \
+"
S = "${WORKDIR}/git/src"
do_compile() {
- oe_runmake
+ # Makefile.housekeeping:111: GNU gold is unsuitable for building iPXE
+ # Makefile.housekeeping:112: Use GNU ld instead
+ sed -i 's#\(^LD.*$(CROSS_COMPILE)ld\)$#\1.bfd#g' -i ${S}/Makefile
+ oe_runmake
}
do_install() {