aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-paramiko_2.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-paramiko_2.7.2.bb')
-rw-r--r--recipes-devtools/python/python3-paramiko_2.7.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-paramiko_2.7.2.bb b/recipes-devtools/python/python3-paramiko_2.7.2.bb
new file mode 100644
index 00000000..3d05efb6
--- /dev/null
+++ b/recipes-devtools/python/python3-paramiko_2.7.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Python module that implements the SSH2 protocol"
+HOMEPAGE = "https://github.com/paramiko/paramiko"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fd0120fc2e9f841c73ac707a30389af5"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "7f36f4ba2c0d81d219f4595e35f70d56cc94f9ac40a6acdf51d6ca210ce65035"
+
+RDEPENDS_${PN} += " \
+ python3-bcrypt \
+ python3-cryptography \
+ python3-pyasn1 \
+ python3-nacl \
+"