aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch29
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.29.1.bb (renamed from recipes-containers/docker-compose/python3-docker-compose_1.28.2.bb)4
2 files changed, 16 insertions, 17 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
index 2576bb1d..7205d3b5 100644
--- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
+++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
@@ -14,42 +14,41 @@ Signed-off-by: Ming Liu <liu.ming50@gmail.com>
setup.py | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
-Index: docker-compose-1.28.2/setup.py
+Index: docker-compose-1.29.1/setup.py
===================================================================
---- docker-compose-1.28.2.orig/setup.py
-+++ docker-compose-1.28.2/setup.py
-@@ -25,17 +25,17 @@
+--- docker-compose-1.29.1.orig/setup.py
++++ docker-compose-1.29.1/setup.py
+@@ -25,16 +25,21 @@
install_requires = [
-- 'cached-property >= 1.2.0, < 2',
- 'docopt >= 0.6.1, < 1',
- 'PyYAML >= 3.10, < 6',
- 'requests >= 2.20.0, < 3',
- 'texttable >= 0.9.0, < 2',
-- 'websocket-client >= 0.32.0, < 1',
-- 'distro >= 1.5.0, < 2',
-- 'docker[ssh] >= 4.4.0, < 5',
-- 'dockerpty >= 0.4.1, < 1',
-- 'jsonschema >= 2.5.1, < 4',
-- 'python-dotenv >= 0.13.0, < 1',
-+ 'cached-property >= 1.2.0',
+ 'docopt >= 0.6.1',
+ 'PyYAML >= 3.10',
+ 'requests >= 2.20.0',
+ 'texttable >= 0.9.0',
+ 'websocket-client >= 0.32.0, < 1',
+ 'distro >= 1.5.0, < 2',
+- 'docker[ssh] >= 5',
++ 'docker[ssh] >= 4.4.0, < 5',
+ 'dockerpty >= 0.4.1, < 1',
+ 'jsonschema >= 2.5.1, < 4',
+- 'python-dotenv >= 0.13.0, < 1',
+ 'websocket-client >= 0.32.0',
+ 'distro >= 1.5.0',
-+ 'docker[ssh] >= 4.4.0',
++ 'docker[ssh] >= 5',
+ 'dockerpty >= 0.4.1',
+ 'jsonschema >= 2.5.1',
+ 'python-dotenv >= 0.13.0',
]
-@@ -51,7 +51,7 @@
- extras_require = {
+@@ -51,7 +56,7 @@
':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
+ ':python_version < "3.8"': ['cached-property >= 1.2.0, < 2'],
':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.28.2.bb b/recipes-containers/docker-compose/python3-docker-compose_1.29.1.bb
index 1c1aa9bc..d74f742e 100644
--- a/recipes-containers/docker-compose/python3-docker-compose_1.28.2.bb
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.29.1.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
inherit pypi setuptools3
-SRC_URI[md5sum] = "48486752654e04eef6c8a79f0d279b30"
-SRC_URI[sha256sum] = "2f148b590414915d029dad7551f4cdf0b03a774dc9baa674480217236d260cc1"
+SRC_URI[md5sum] = "49c202544c7e2eadbbe45da8e838ae02"
+SRC_URI[sha256sum] = "d2064934f5084db8a0c4805e226447bf1fd0c928419be95afb6bd1866838c1f1"
SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \