aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python3-boto3_1.14.7.bb2
-rw-r--r--recipes-devtools/python/python3-botocore_1.20.36.bb12
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-boto3_1.14.7.bb b/recipes-devtools/python/python3-boto3_1.14.7.bb
index f9e979e8..0e9611ca 100644
--- a/recipes-devtools/python/python3-boto3_1.14.7.bb
+++ b/recipes-devtools/python/python3-boto3_1.14.7.bb
@@ -13,3 +13,5 @@ SRC_URI[md5sum] = "fb8b77d4ac10a971570419dd3613196e"
SRC_URI[sha256sum] = "4856c8cb4150b900cc7dccbdf16f542fb8c12e97b17639979e58760847f7cf35"
inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-botocore python3-urllib3 python3-unixadmin"
diff --git a/recipes-devtools/python/python3-botocore_1.20.36.bb b/recipes-devtools/python/python3-botocore_1.20.36.bb
new file mode 100644
index 00000000..4c4a8251
--- /dev/null
+++ b/recipes-devtools/python/python3-botocore_1.20.36.bb
@@ -0,0 +1,12 @@
+SUMMARY = "The low-level, core functionality of boto 3."
+HOMEPAGE = "https://github.com/boto/botocore"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI = "git://github.com/boto/botocore.git;protocol=https"
+SRCREV = "8c7123bd4683049dcac62bf3e11662e6a72c5eec"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += "python3-jmespath python3-dateutil python3-logging"