aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/optee/optee-os_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee/optee-os_%.bbappend')
-rw-r--r--recipes-security/optee/optee-os_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index d7e81c5a..4043b8d7 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -1,3 +1,18 @@
+FILESEXTRAPATHS_prepend_ti-soc := "${THISDIR}/${PN}:"
+
+PV_ti-soc = "3.11.0+git${SRCPV}"
+
+SRCREV_ti-soc = "c4def2a8262a03244d9a88461699b9b8e43c6b55"
+
+SRC_URI_ti-soc = " \
+ git://github.com/OP-TEE/optee_os.git \
+ file://0006-allow-setting-sysroot-for-libgcc-lookup.patch \
+ file://0007-allow-setting-sysroot-for-clang.patch \
+ file://0001-libutils-provide-empty-__getauxval-implementation.patch \
+ file://0002-link.mk-implement-support-for-libnames-after-libgcc-.patch \
+ file://0003-ta_dev_kit.mk-make-sure-that-libutils-is-linked-seco.patch \
+"
+
do_compile_prepend_ti-soc() {
export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
}