aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
index 4dedb83b..77a29ec8 100644
--- a/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
+++ b/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=75859989545e37968a99b631ef42722e"
# This package builds a kernel module, use kernel PR as base and append a local
-MACHINE_KERNEL_PR_append = "a"
+MACHINE_KERNEL_PR_append = "b"
PR = "${MACHINE_KERNEL_PR}"
PV_append = "+git${SRCPV}"
@@ -15,7 +15,7 @@ PLATFORM = ""
PLATFORM_dra7xx = "DRA7xx_PLATFORM"
PLATFORM_keystone = "KEYSTONE_PLATFORM"
-EXTRA_OEMAKE = "PLATFORM=${PLATFORM}"
+EXTRA_OEMAKE = "PLATFORM=${PLATFORM} KVERSION=${KERNEL_VERSION} KERNEL_SRC=${STAGING_KERNEL_DIR}"
# The following is to prevent an unused configure.ac from erroneously
# triggering the QA check for gettext.
@@ -29,4 +29,4 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
include gdbc6x.inc
-module_autoload_gdbserverproxy = "gdbserverproxy"
+KERNEL_MODULE_AUTOLOAD += "gdbserverproxy"