aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/ti-pdk.bbclass7
-rw-r--r--recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch50
-rw-r--r--recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb5
3 files changed, 61 insertions, 1 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index ab730a90..540a665c 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -59,17 +59,24 @@ TI_PDK_LIMIT_SOCS ?= ""
TI_PDK_LIMIT_BOARDS ?= ""
TI_PDK_MAKE_TARGET ?= "release"
TI_PDK_EXTRA_MAKE ?= ""
+TI_PDK_DOXYGEN_SUPPORT ?= "1"
TI_PDK_XDC_ARGS ?= "${TI_PDK_LIMIT_SOCS}"
PARALLEL_XDC = "--jobs=${BB_NUMBER_THREADS}"
PARALLEL_MAKE = ""
+def get_doxygen_support(d):
+ if d.getVar('TI_PDK_DOXYGEN_SUPPORT', True) == '1':
+ return ''
+ return 'DOXYGEN_SUPPORT=no'
+
EXTRA_OEMAKE = " \
LIMIT_SOCS="${TI_PDK_LIMIT_SOCS}" \
LIMIT_BOARDS="${TI_PDK_LIMIT_BOARDS}" \
LIMIT_CORES="${TI_PDK_LIMIT_CORES}" \
${TI_PDK_EXTRA_MAKE} \
+ ${@get_doxygen_support(d)} \
"
do_configure() {
diff --git a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch
new file mode 100644
index 00000000..2a10d37e
--- /dev/null
+++ b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch
@@ -0,0 +1,50 @@
+From e5dfce58161aaee80ca45c3e992a059efac459d7 Mon Sep 17 00:00:00 2001
+From: Joshua Watt <JPEWhacker@gmail.com>
+Date: Wed, 21 Feb 2018 13:38:35 -0600
+Subject: [PATCH] comp_mk: Allow doxygen support to be overridden
+
+Support for Doxygen can be globally disabled by setting the
+DOXYGEN_SUPPORT environment variable to "no"
+
+Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
+---
+ comp_top.mk | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/comp_top.mk b/comp_top.mk
+index 28700ba..e331132 100644
+--- a/comp_top.mk
++++ b/comp_top.mk
+@@ -114,6 +114,11 @@ comp_FIRM_LIST_CLEAN = $(addsuffix _clean, $($(COMP)_FIRM_LIST))
+ comp_PKG_LIST_ALL_CLEAN = $(addsuffix _clean, $(comp_PKG_LIST_ALL))
+ comp_PKG_LIST_PACKAGE = $(addsuffix _package, $(comp_PKG_LIST_ALL))
+
++# If the component enables doxygen, this will evaluate to "yesyes" and doxygen
++# will be built. If this value is overridden by the user to any other value, or
++# $(COMP)_DOXYGEN_SUPPORT is not "yes", doxygen is not built.
++DOXYGEN_SUPPORT ?= yes$($(COMP)_DOXYGEN_SUPPORT)
++
+ .PHONY : apps appcores app_clean clean_appcores \
+ lib libcores lib_allendians lib_clean clean_libcores clean_lib_allendians \
+ all comp_libs comp_libs_clean examples examples_clean clean package $(comp_PKG_LIST_ALL) \
+@@ -230,7 +235,7 @@ xdc_meta_clean:
+ $(XDC) clean XDCBUILDCFG=config_mk.bld
+
+ doxygen:
+-ifeq ($($(COMP)_DOXYGEN_SUPPORT),yes)
++ifeq ($(DOXYGEN_SUPPORT),yesyes)
+ $(ECHO) Creating Doxygen API guide ...
+ @doxygen docs/Doxyfile
+ else
+@@ -238,7 +243,7 @@ else
+ endif
+
+ clean_doxygen:
+-ifeq ($($(COMP)_DOXYGEN_SUPPORT),yes)
++ifeq ($(DOXYGEN_SUPPORT),yesyes)
+ $(ECHO) cleaned Doxygen API guide ...
+ $(RM) -rf docs/doxygen
+ else
+--
+2.14.3
+
diff --git a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb
index 0999b5c5..fbb82ace 100644
--- a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb
+++ b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb
@@ -15,7 +15,10 @@ PDK_BUILD_GIT_BRANCH = "master"
PDK_BUILD_SRCREV = "cbac264f08aa9cdc2cd533d1433ef57b922cccb5"
BRANCH = "${PDK_BUILD_GIT_BRANCH}"
-SRC_URI = "${PDK_BUILD_GIT_URI};protocol=${PDK_BUILD_GIT_PROTOCOL};branch=${BRANCH}"
+SRC_URI = "\
+ ${PDK_BUILD_GIT_URI};protocol=${PDK_BUILD_GIT_PROTOCOL};branch=${BRANCH} \
+ file://0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch \
+ "
SRCREV = "${PDK_BUILD_SRCREV}"