aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch46
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb3
2 files changed, 48 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch
new file mode 100644
index 00000000..b79a8844
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch
@@ -0,0 +1,46 @@
+From 31d430d8db335b7c3fea08b6aa8309b90b8f2cb9 Mon Sep 17 00:00:00 2001
+From: Tom Rini <trini@ti.com>
+Date: Tue, 8 Nov 2011 08:07:47 +0100
+Subject: [PATCH 8/8] HACK: am335x evm: turn d-cache on globally, turn it off when doing nfs stuff
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ board/ti/am335x/evm.c | 12 ++++++++++++
+ include/configs/am335x_evm.h | 1 +
+ 2 files changed, 13 insertions(+), 0 deletions(-)
+
+diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c
+index bc1119e..e64626a 100644
+--- a/board/ti/am335x/evm.c
++++ b/board/ti/am335x/evm.c
+@@ -1041,3 +1041,15 @@ U_BOOT_CMD(
+
+ #endif /* CONFIG_NAND_TI81XX */
+ #endif /* CONFIG_SPL_BUILD */
++
++/*
++ * Not all drivers we use (such as ethernet) are dcache safe. But
++ * we need cache on to boot quickly enough.
++ */
++#ifndef CONFIG_SYS_DCACHE_OFF
++void enable_caches(void)
++{
++ /* Enable D-cache. I-cache is already enabled in start.S */
++ dcache_enable();
++}
++#endif
+diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
+index 8bf3ff1..58fa2f6 100755
+--- a/include/configs/am335x_evm.h
++++ b/include/configs/am335x_evm.h
+@@ -119,6 +119,7 @@
+ "bootm ${loadaddr}\0" \
+ "net_boot=echo Booting from network ...; " \
+ "setenv autoload no; " \
++ "dcache off; " \
+ "dhcp; " \
+ "tftp ${loadaddr} ${bootfile}; " \
+ "run net_args; " \
+--
+1.7.2.5
+
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 2e0115f0..fd7d99c4 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
COMPATIBLE_MACHINE = "(ti33x)"
DEFAULT_PREFERENCE_ti33x = "99"
PV = "2011.09+git"
-PR = "r20"
+PR = "r21"
# SPL build
UBOOT_BINARY = "u-boot.img"
@@ -19,6 +19,7 @@ SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;br
file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \
file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \
file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \
+ file://2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch \
"
SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"