aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README47
1 files changed, 42 insertions, 5 deletions
diff --git a/README b/README
index 9be700e..f82f781 100644
--- a/README
+++ b/README
@@ -1,8 +1,45 @@
+meta-qt3
+========
+This layer is just for passing LSB test because qt3 is one test item of LSB.
+You can get qt3 with two kinds of images(LSB image or custom image) \
+according to the following steps.
-README for meta-qt3
+---------------------------
+Get LSB image including qt3
+---------------------------
+1 Enter poky directory
+ $ls
+ bitbake ... meta meta-demoapps meta-rt meta-yocto oe-init-build-env ... scripts
-To use this branch, add the path to this directory to your
-conf/bblayers.conf file.
+2 Add meta-qt3 path to build/conf/bblayers.conf file
-You may also have to set DISTRO = "poky-lsb" in your conf/local.conf
-file.
+3 Set DISTRO = "poky-lsb" in build/conf/local.conf file
+
+4 Build lsb-image including qt3
+ $ bitbake core-image-lsb-qt3
+
+Note: "core-image-lsb-qt3" is the image to meet the demands of LSB.
+
+-----------------------------
+Get qt3 for your custom image
+-----------------------------
+1 Enter poky directory
+ $ls
+ bitbake build ... meta ... meta-qt3 ... meta-yocto oe-init-build-env ... scripts
+
+2 Add meta-qt3 path to build/conf/bblayers.conf file
+
+3 Add task-core-qt3 file to your custom image.
+ For example, core-image-custom.bb is your building image file.
+ Go to your directory including your core-image-custom.bb file.
+ $vi core-image-custom.bb
+ .......
+ IMAGE_INSTALL = "\
+ ${POKY_BASE_INSTALL} \
+ task-core-basic \
++ task-core-qt3 \
+ "
+ ......
+
+4 Build your custom image in build directory
+ $ bitbake core-image-custom