aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README39
1 files changed, 34 insertions, 5 deletions
diff --git a/README b/README
index 9be700e..b74bee2 100644
--- a/README
+++ b/README
@@ -1,8 +1,37 @@
+meta-qt3
+========
-README for meta-qt3
+This layer provides Qt 3.x libraries. Its intended use is for passing LSB tests
+as Qt3 is a requirement for LSB; however the libraries may also be used for any
+other purpose requiring Qt3.
-To use this branch, add the path to this directory to your
-conf/bblayers.conf file.
+--------------------------------
+Build an LSB image including Qt3
+--------------------------------
-You may also have to set DISTRO = "poky-lsb" in your conf/local.conf
-file.
+You can build an LSB image including Qt3 using the following steps:
+
+1. Add meta-qt3 path to COREBASE/build/conf/bblayers.conf file
+
+2. Set DISTRO = "poky-lsb" in COREBASE/build/conf/local.conf file
+
+3. Build lsb-image including qt3
+ $ bitbake core-image-lsb-qt3
+
+Note: "core-image-lsb-qt3" is the image prepared to meet the demands of LSB.
+
+--------------------------------
+Include Qt3 in your custom image
+--------------------------------
+
+If you only want to add Qt3 to your custom image, then you should perform
+the following steps:
+
+1. Add meta-qt3 path to COREBASE/build/conf/bblayers.conf file
+
+2. Add task-core-qt3 file to your custom image.
+ For example, if core-image-custom.bb is your building image file,
+ then you should add task-core-qt3 to IMAGE_INSTALL in core-image-custom.bb
+
+3. Build your custom image in build directory
+ $ bitbake core-image-custom