aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qdl/qdl_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qdl/qdl_git.bb')
-rw-r--r--recipes-devtools/qdl/qdl_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/qdl/qdl_git.bb b/recipes-devtools/qdl/qdl_git.bb
new file mode 100644
index 0000000..462406c
--- /dev/null
+++ b/recipes-devtools/qdl/qdl_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "QDL flasing tool"
+HOMEPAGE = "https://github.com/andersson/qdl.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://qdl.c;beginline=1;endline=31;md5=1c7d712d897368d3d3c161e5493efc6a"
+
+DEPENDS = "libxml2"
+
+SRCREV = "760b3dffb03d2b7dfb82c6eac652a092f51c572d"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
+ file://0001-Makefile-Use-pkg-config-for-libxml2-detection.patch"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+}
+
+BBCLASSEXTEND = "native nativesdk"