aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/qcom-sdm845.inc1
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend6
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend1
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_5.2.bb (renamed from recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb)6
-rw-r--r--recipes-kernel/linux/linux-qcom-bootimg.inc5
5 files changed, 14 insertions, 5 deletions
diff --git a/conf/machine/include/qcom-sdm845.inc b/conf/machine/include/qcom-sdm845.inc
index 59ffd84..48e9fe1 100644
--- a/conf/machine/include/qcom-sdm845.inc
+++ b/conf/machine/include/qcom-sdm845.inc
@@ -24,6 +24,7 @@ PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
+ qrtr-apps \
"
IMAGE_FSTYPES ?= "ext4.gz"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 18fc1dd..7a14a57 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -2,6 +2,7 @@
GALLIUMDRIVERS_append_apq8064 = ",freedreno"
GALLIUMDRIVERS_append_apq8016 = ",freedreno"
GALLIUMDRIVERS_append_apq8096 = ",freedreno"
+GALLIUMDRIVERS_append_sdm845 = ",freedreno"
PACKAGECONFIG_append_apq8064 = " \
gallium \
@@ -17,3 +18,8 @@ PACKAGECONFIG_append_apq8096 = " \
gallium \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
"
+
+PACKAGECONFIG_append_sdm845 = " \
+ gallium \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index 0d8fc57..04856c9 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -3,3 +3,4 @@
PACKAGECONFIG_append_apq8064 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' dri3 xshmfence glamor', '', d)}"
PACKAGECONFIG_append_apq8016 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' dri3 xshmfence glamor', '', d)}"
PACKAGECONFIG_append_apq8096 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' dri3 xshmfence glamor', '', d)}"
+PACKAGECONFIG_append_sdm845 = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' dri3 xshmfence glamor', '', d)}"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb b/recipes-kernel/linux/linux-linaro-qcomlt_5.2.bb
index 7a85c39..86d5ee6 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt_5.1.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_5.2.bb
@@ -1,7 +1,7 @@
# Copyright (C) 2014-2019 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)
-DESCRIPTION = "Linaro Qualcomm Landing team 5.1 Kernel"
+DESCRIPTION = "Linaro Qualcomm Landing team 5.2 Kernel"
LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
inherit pythonnative
@@ -10,8 +10,8 @@ require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc
LOCALVERSION ?= "-linaro-lt-qcom"
-SRCBRANCH ?= "release/db845c/qcomlt-5.1"
-SRCREV ?= "269afa82ce428ba37323c1fe7572943eccab9e71"
+SRCBRANCH ?= "release/db845c/qcomlt-5.2"
+SRCREV ?= "a5ea95c538e3d86feb21e048d44b68fd048a27b2"
COMPATIBLE_MACHINE = "(sdm845)"
diff --git a/recipes-kernel/linux/linux-qcom-bootimg.inc b/recipes-kernel/linux/linux-qcom-bootimg.inc
index 7290f27..1c7c055 100644
--- a/recipes-kernel/linux/linux-qcom-bootimg.inc
+++ b/recipes-kernel/linux/linux-qcom-bootimg.inc
@@ -10,6 +10,8 @@ BOOT_IMAGE_BASE_NAME = "boot-${KERNEL_IMAGE_NAME}"
BOOT_IMAGE_SYMLINK_NAME = "boot-${KERNEL_IMAGE_LINK_NAME}"
SD_BOOT_IMAGE_BASE_NAME = "boot-sd${KERNEL_IMAGE_NAME}"
SD_BOOT_IMAGE_SYMLINK_NAME = "boot-sd-${KERNEL_IMAGE_LINK_NAME}"
+KERNEL_CMDLINE = "root=/dev/${1} rw rootwait console=${ttydev},${baudrate}n8"
+KERNEL_CMDLINE_append_dragonboard-845c = " clk_ignore_unused pd_ignore_unused"
# param ${1} partition where rootfs is located
# param ${2} output boot image file name
@@ -20,8 +22,7 @@ priv_make_image() {
$mkbootimg_dtarg \
--pagesize ${QCOM_BOOTIMG_PAGE_SIZE} \
--base ${QCOM_BOOTIMG_KERNEL_BASE} \
- --cmdline \
- "root=/dev/${1} rw rootwait console=${ttydev},${baudrate}n8"
+ --cmdline "${KERNEL_CMDLINE}"
}
do_deploy_append() {