aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch31
-rw-r--r--recipes-devtools/qdl/qdl_git.bb22
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch b/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch
new file mode 100644
index 0000000..d5f63c4
--- /dev/null
+++ b/recipes-devtools/qdl/files/0001-Makefile-Use-pkg-config-for-libxml2-detection.patch
@@ -0,0 +1,31 @@
+From d0ecd95e8935a9fe3e94921d10bfb153f5e0ce52 Mon Sep 17 00:00:00 2001
+From: Nicolas Dechesne <nicolas.dechesne@linaro.org>
+Date: Wed, 28 Aug 2019 17:54:50 +0200
+Subject: [PATCH] Makefile: Use pkg-config for libxml2 detection.
+
+xml2-config does not work. Use pkgconfig to set CPPFLAGS and LIBS.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0a934ff..f18393d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ OUT := qdl
+
+-CFLAGS := -O2 -Wall -g `xml2-config --cflags`
+-LDFLAGS := `xml2-config --libs` -ludev
++CFLAGS := -O2 -Wall -g `pkg-config --cflags libxml-2.0`
++LDFLAGS := `pkg-config --libs libxml-2.0` -ludev
+ prefix := /usr/local
+
+ SRCS := firehose.c qdl.c sahara.c util.c patch.c program.c ufs.c
+--
+2.23.0
+
diff --git a/recipes-devtools/qdl/qdl_git.bb b/recipes-devtools/qdl/qdl_git.bb
new file mode 100644
index 0000000..462406c
--- /dev/null
+++ b/recipes-devtools/qdl/qdl_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "QDL flasing tool"
+HOMEPAGE = "https://github.com/andersson/qdl.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://qdl.c;beginline=1;endline=31;md5=1c7d712d897368d3d3c161e5493efc6a"
+
+DEPENDS = "libxml2"
+
+SRCREV = "760b3dffb03d2b7dfb82c6eac652a092f51c572d"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
+ file://0001-Makefile-Use-pkg-config-for-libxml2-detection.patch"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+}
+
+BBCLASSEXTEND = "native nativesdk"