aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-test/diag/diag_git.bb21
-rw-r--r--recipes-test/images/initramfs-bootrr-image.bb2
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes-test/diag/diag_git.bb b/recipes-test/diag/diag_git.bb
new file mode 100644
index 0000000..640c537
--- /dev/null
+++ b/recipes-test/diag/diag_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "DIAG implements routing of diagnostics related messages between host and various subsystems."
+HOMEPAGE = "https://github.com/andersson/diag"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f6832ae4af693c6f31ffd931e25ef580"
+
+SRC_URI = "git://github.com/andersson/diag.git;protocol=https"
+
+PV = "0.0+git${SRCPV}"
+SRCREV = "9de0697ec5447dddbc0caf5744042e41a3a7c2ea"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "qrtr udev"
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install 'DESTDIR=${D}'
+}
diff --git a/recipes-test/images/initramfs-bootrr-image.bb b/recipes-test/images/initramfs-bootrr-image.bb
index 93054bd..d1c4859 100644
--- a/recipes-test/images/initramfs-bootrr-image.bb
+++ b/recipes-test/images/initramfs-bootrr-image.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Small ramdisk image for running bootrr"
-PACKAGE_INSTALL = "bootrr-init busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} qrtr-apps udev bootrr rmtfs gptfdisk lava-test-shell"
+PACKAGE_INSTALL = "bootrr-init busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} qrtr-apps udev bootrr rmtfs gptfdisk lava-test-shell diag"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = ""