aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-test/bootrr/bootrr.bb16
-rw-r--r--recipes-test/images/initramfs-bootrr-image.bb2
-rw-r--r--recipes-test/initrdscripts/bootrr-init.bb14
-rw-r--r--recipes-test/initrdscripts/files/init-debug.sh50
4 files changed, 1 insertions, 81 deletions
diff --git a/recipes-test/bootrr/bootrr.bb b/recipes-test/bootrr/bootrr.bb
deleted file mode 100644
index 759114c..0000000
--- a/recipes-test/bootrr/bootrr.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Boot regression testing (bootrr) for Qualcomm boards"
-SECTION = "test"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SRCREV = "2a0a7ab0c77776810ed1d9b266ec0a59c558378e"
-SRC_URI = "git://git@github.com/andersson/${BPN}.git;branch=master;protocol=https"
-
-PV = "0.0+${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-do_install() {
- oe_runmake install DESTDIR=${D} prefix=${prefix}
-}
diff --git a/recipes-test/images/initramfs-bootrr-image.bb b/recipes-test/images/initramfs-bootrr-image.bb
index d1c4859..c9abfa6 100644
--- a/recipes-test/images/initramfs-bootrr-image.bb
+++ b/recipes-test/images/initramfs-bootrr-image.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Small ramdisk image for running bootrr"
-PACKAGE_INSTALL = "bootrr-init busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} qrtr-apps udev bootrr rmtfs gptfdisk lava-test-shell diag"
+PACKAGE_INSTALL = "busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} qrtr-apps udev rmtfs gptfdisk lava-test-shell diag"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = ""
diff --git a/recipes-test/initrdscripts/bootrr-init.bb b/recipes-test/initrdscripts/bootrr-init.bb
deleted file mode 100644
index e302996..0000000
--- a/recipes-test/initrdscripts/bootrr-init.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Basic init script to launch test scripts"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-SRC_URI = "file://init-debug.sh"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -m 0755 ${WORKDIR}/init-debug.sh ${D}/init
-}
-
-inherit allarch
-
-FILES_${PN} += " /init "
diff --git a/recipes-test/initrdscripts/files/init-debug.sh b/recipes-test/initrdscripts/files/init-debug.sh
deleted file mode 100644
index 2cab1e7..0000000
--- a/recipes-test/initrdscripts/files/init-debug.sh
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh
-
-HOME=/root
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-PS1="linaro-test [rc=$(echo \$?)]# "
-export HOME PS1 PATH
-
-do_mount_fs() {
- grep -q "$1" /proc/filesystems || return
- test -d "$2" || mkdir -p "$2"
- mount -t "$1" "$1" "$2"
-}
-
-do_mknod() {
- test -e "$1" || mknod "$1" "$2" "$3" "$4"
-}
-
-mkdir -p /proc
-mount -t proc proc /proc
-
-do_mount_fs sysfs /sys
-do_mount_fs debugfs /sys/kernel/debug
-do_mount_fs devtmpfs /dev
-do_mount_fs devpts /dev/pts
-do_mount_fs tmpfs /dev/shm
-
-mkdir -p /run
-mkdir -p /var/run
-
-/sbin/udevd --daemon
-/bin/udevadm trigger
-
-do_mknod /dev/console c 5 1
-do_mknod /dev/null c 1 3
-do_mknod /dev/zero c 1 5
-
-echo -n 'BOOT TIME: '
-cat /proc/uptime
-
-if $(grep -q bootrr-auto /proc/cmdline); then
- for TEST in $(tr "\0" "\n" < /proc/device-tree/compatible); do
- if [ -x "/usr/bin/${TEST}" ]; then
- /usr/bin/${TEST}
- fi
- done
-
- echo ~~~~~~~~~~~~~~~~~~~~~
-fi
-
-exec sh </dev/console >/dev/console 2>/dev/console