aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/qmic/qmic/0001-Makefile-Allow-compiler-linker-flags-to-be-overridde.patch32
-rw-r--r--recipes-devtools/qmic/qmic_git.bb6
-rw-r--r--recipes-support/qrtr/qrtr_git.bb2
-rw-r--r--recipes-support/rmtfs/rmtfs_git.bb6
4 files changed, 6 insertions, 40 deletions
diff --git a/recipes-devtools/qmic/qmic/0001-Makefile-Allow-compiler-linker-flags-to-be-overridde.patch b/recipes-devtools/qmic/qmic/0001-Makefile-Allow-compiler-linker-flags-to-be-overridde.patch
deleted file mode 100644
index 7752de6..0000000
--- a/recipes-devtools/qmic/qmic/0001-Makefile-Allow-compiler-linker-flags-to-be-overridde.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 60c295e1a7852ab5311b0f3be6945a37c8256a2a Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 6 Apr 2017 22:02:30 +0000
-Subject: [PATCH] Makefile: Allow compiler/linker flags to be overridden
-
-This helps with cross compilation where toolchains specify
-certain flags via environment e.g. CFLAGS/LDFLAGS
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Makefile | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 0783e49..2efba54 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,8 +1,8 @@
- OUT := qmic
-
--CFLAGS := -Wall -g -O2
--LDFLAGS :=
--prefix := /usr/local
-+CFLAGS ?= -Wall -g -O2
-+LDFLAGS ?=
-+prefix ?= /usr/local
-
- SRCS := qmic.c qmi_message.c qmi_struct.c
- OBJS := $(SRCS:.c=.o)
---
-1.9.1
-
diff --git a/recipes-devtools/qmic/qmic_git.bb b/recipes-devtools/qmic/qmic_git.bb
index 0c3b126..536ad93 100644
--- a/recipes-devtools/qmic/qmic_git.bb
+++ b/recipes-devtools/qmic/qmic_git.bb
@@ -5,10 +5,8 @@ SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ca25dbf5ebfc1a058bfc657c895aac2f"
-SRCREV = "1c036374ea1dd7a831821efbe3ee686e2a1842fe"
-SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
- file://0001-Makefile-Allow-compiler-linker-flags-to-be-overridde.patch \
- "
+SRCREV = "4ad63502c5ce3f4fbdf223dc7f58d6ba9bbf5eea"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
PV = "0.0+${SRCPV}"
diff --git a/recipes-support/qrtr/qrtr_git.bb b/recipes-support/qrtr/qrtr_git.bb
index 2d4d1e2..9920de5 100644
--- a/recipes-support/qrtr/qrtr_git.bb
+++ b/recipes-support/qrtr/qrtr_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
inherit systemd
-SRCREV = "dee8a384dc6ba02d41caa1f61d0b267c4ba74ff0"
+SRCREV = "7d9a2e7df9cf901ec28b372185eabf93ec2e11be"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
SRC_URI += "file://qrtr.service"
diff --git a/recipes-support/rmtfs/rmtfs_git.bb b/recipes-support/rmtfs/rmtfs_git.bb
index 86a451f..b3a160a 100644
--- a/recipes-support/rmtfs/rmtfs_git.bb
+++ b/recipes-support/rmtfs/rmtfs_git.bb
@@ -7,16 +7,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ca25dbf5ebfc1a058bfc657c895aac2f"
inherit systemd
-SRCREV = "8c79959935ca67a0cc198e0cb690baae4c46737c"
+SRCREV = "0f800fa4334b03a47941ce1b577f51a69552e414"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
SRC_URI += "file://rmtfs.service"
-DEPENDS = "qmic-native qrtr"
+DEPENDS = "qmic-native qrtr udev"
PV = "0.0+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr'"
+EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr -ludev'"
do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix}