aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/qcom-apq8016.inc4
-rw-r--r--conf/machine/include/qcom-apq8096.inc4
-rw-r--r--conf/machine/include/qcom-sdm845.inc5
-rw-r--r--recipes-support/adsprpc/adsprpc_git.bb14
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb15
5 files changed, 27 insertions, 15 deletions
diff --git a/conf/machine/include/qcom-apq8016.inc b/conf/machine/include/qcom-apq8016.inc
index 08bd660..2688b20 100644
--- a/conf/machine/include/qcom-apq8016.inc
+++ b/conf/machine/include/qcom-apq8016.inc
@@ -27,6 +27,10 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
rmtfs \
"
+MACHINE_EXTRA_RRECOMMENDS += " \
+ fastrpc \
+"
+
# Fastboot expects an ext4 image, which needs to be 4096 aligned
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/conf/machine/include/qcom-apq8096.inc b/conf/machine/include/qcom-apq8096.inc
index 5c65f12..3a6a08b 100644
--- a/conf/machine/include/qcom-apq8096.inc
+++ b/conf/machine/include/qcom-apq8096.inc
@@ -28,6 +28,10 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
rmtfs \
"
+MACHINE_EXTRA_RRECOMMENDS += " \
+ fastrpc \
+"
+
# Fastboot expects an ext4 image, which needs to be 4096 aligned
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/conf/machine/include/qcom-sdm845.inc b/conf/machine/include/qcom-sdm845.inc
index 7f6a1c2..e3839b1 100644
--- a/conf/machine/include/qcom-sdm845.inc
+++ b/conf/machine/include/qcom-sdm845.inc
@@ -24,13 +24,16 @@ PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
- adsprpc \
pd-mapper \
qrtr \
rmtfs \
tqftpserv \
"
+MACHINE_EXTRA_RRECOMMENDS += " \
+ fastrpc \
+"
+
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT = "4096"
diff --git a/recipes-support/adsprpc/adsprpc_git.bb b/recipes-support/adsprpc/adsprpc_git.bb
deleted file mode 100644
index 430c1ee..0000000
--- a/recipes-support/adsprpc/adsprpc_git.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/libadsprpc.git"
-SECTION = "devel"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e868d7526728e9b1c0c4f34730d27754"
-
-SRCREV = "741c1415df731503b3aea8b754223a871081d2f3"
-SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/libadsprpc.git;branch=master;protocol=https"
-
-PV = "0.0+${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-inherit autotools
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
new file mode 100644
index 0000000..f15a958
--- /dev/null
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -0,0 +1,15 @@
+HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git"
+SUMMARY = "Qualcomm FastRPC applications and library"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f94f3a7beba14ae2f59f817e9634f891"
+
+SRCREV = "a28fcb0f247f6c1a9f915dc318d931256edabeac"
+SRC_URI = "git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit autotools