aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/firmware/firmware-qcom-dragonboard410c_1034.2.1.bb3
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb19
2 files changed, 21 insertions, 1 deletions
diff --git a/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1034.2.1.bb b/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1034.2.1.bb
index b65ac46..62e5bf4 100644
--- a/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1034.2.1.bb
+++ b/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1034.2.1.bb
@@ -24,8 +24,9 @@ do_install() {
cp -r ./proprietary-linux/* ${D}${nonarch_base_libdir}/firmware/
cp ./efs-seed/fs_image_linux.tar.gz.mbn.img ${D}/boot/modem_fsg
+ install -d ${D}${nonarch_base_libdir}/firmware/qcom/msm8916
MTOOLS_SKIP_CHECK=1 mcopy -i ./bootloaders-linux/NON-HLOS.bin \
- ::image/modem.* ::image/mba.mbn ::image/wcnss.* ${D}${nonarch_base_libdir}/firmware/
+ ::image/modem.* ::image/mba.mbn ::image/wcnss.* ${D}${nonarch_base_libdir}/firmware/qcom/msm8916
# Venus firmware have been merged in linux-firmware in a different location than
# what we've been using for now. Let's add symlinks for now, until we switch to linux-firmware
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb b/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb
new file mode 100644
index 0000000..b25dbe1
--- /dev/null
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_5.4.bb
@@ -0,0 +1,19 @@
+# Copyright (C) 2014-2019 Linaro
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Linaro Qualcomm Landing team 5.4 Kernel"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+inherit pythonnative
+
+require recipes-kernel/linux/linux-linaro-qcom.inc
+require recipes-kernel/linux/linux-qcom-bootimg.inc
+
+LOCALVERSION ?= "-linaro-lt-qcom"
+SRCBRANCH ?= "release/qcomlt-5.4"
+SRCREV ?= "9a980779332866fe32e66fa949e5cbc19a35e453"
+
+COMPATIBLE_MACHINE = "(apq8016|apq8096|sdm845)"
+
+# Wifi firmware has a recognizable arch :(
+ERROR_QA_remove = "arch"