aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--conf/machine/include/qcom-common.inc2
-rw-r--r--dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine4
-rw-r--r--dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs_%.bbappend5
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_5.11.bb15
-rw-r--r--recipes-support/qrtr/qrtr_git.bb4
-rw-r--r--recipes-support/rmtfs/rmtfs_git.bb2
7 files changed, 31 insertions, 3 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 5f3db02..821a90a 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -15,4 +15,6 @@ BBFILES_DYNAMIC += " \
openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \
networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \
networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bbappend \
+ backports:${LAYERDIR}/dynamic-layers/backports-layer/*/*/*.bb \
+ backports:${LAYERDIR}/dynamic-layers/backports-layer/*/*/*.bbappend \
"
diff --git a/conf/machine/include/qcom-common.inc b/conf/machine/include/qcom-common.inc
index 272ab6a..d2434f9 100644
--- a/conf/machine/include/qcom-common.inc
+++ b/conf/machine/include/qcom-common.inc
@@ -22,6 +22,8 @@ PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
+PREFERRED_PROVIDER_android-tools-conf = "android-tools-conf-configfs"
+
# Fastboot expects an ext4 image, which needs to be 4096 aligned
IMAGE_FSTYPES ?= "ext4.gz"
IMAGE_ROOTFS_ALIGNMENT ?= "4096"
diff --git a/dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine b/dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine
new file mode 100644
index 0000000..37f26bb
--- /dev/null
+++ b/dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine
@@ -0,0 +1,4 @@
+manufacturer=Qualcomm
+model=`hostname`
+androidserial="$(sed -n -e '/androidboot.serialno/ s/.*androidboot.serialno=\([^ ]*\).*/\1/gp ' /proc/cmdline)"
+[ -n "$androidserial" ] && serial="$androidserial"
diff --git a/dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs_%.bbappend b/dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs_%.bbappend
new file mode 100644
index 0000000..1e314d8
--- /dev/null
+++ b/dynamic-layers/backports-layer/recipes-devtools/android-tools/android-tools-conf-configfs_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_append_qcom = " \
+ file://android-gadget-setup.machine \
+"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_5.11.bb b/recipes-kernel/linux/linux-linaro-qcomlt_5.11.bb
new file mode 100644
index 0000000..31ebe58
--- /dev/null
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_5.11.bb
@@ -0,0 +1,15 @@
+# Copyright (C) 2014-2020 Linaro
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Linaro Qualcomm Landing team 5.11 Kernel"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+require recipes-kernel/linux/linux-linaro-qcom.inc
+require recipes-kernel/linux/linux-qcom-bootimg.inc
+
+LOCALVERSION ?= "-linaro-lt-qcom"
+
+SRCBRANCH = "release/rb5/qcomlt-5.11"
+SRCREV = "c53a93b858f8166115bbe728a9a2a39bf7d0a91d"
+
+COMPATIBLE_MACHINE = "(sm8250)"
diff --git a/recipes-support/qrtr/qrtr_git.bb b/recipes-support/qrtr/qrtr_git.bb
index 9daf6ba..def23be 100644
--- a/recipes-support/qrtr/qrtr_git.bb
+++ b/recipes-support/qrtr/qrtr_git.bb
@@ -7,10 +7,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
inherit systemd
-SRCREV = "983b223423f3ec36f231455b6a93bc2a10921794"
+SRCREV = "9dc7a88548c27983e06465d3fbba2ba27d4bc050"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
-PV = "0.0+${SRCPV}"
+PV = "0.3+${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/recipes-support/rmtfs/rmtfs_git.bb b/recipes-support/rmtfs/rmtfs_git.bb
index 08169fc..249e21e 100644
--- a/recipes-support/rmtfs/rmtfs_git.bb
+++ b/recipes-support/rmtfs/rmtfs_git.bb
@@ -11,7 +11,7 @@ SRCREV = "1cc12d3dc1f251f6d3151970621a06fdd013a1d0"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
DEPENDS = "qmic-native qrtr udev"
-PV = "0.0+${SRCPV}"
+PV = "0.2+${SRCPV}"
S = "${WORKDIR}/git"