aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend52
1 files changed, 26 insertions, 26 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
index 3e90610..f6c5709 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -1,26 +1,26 @@
-LIB_DEPS := "${@oe_filter_out('mesa-dri', '${LIB_DEPS}', d)}"
-LIB_DEPS += "virtual/libgl"
-
-FILESEXTRAPATHS := "${THISDIR}/${PN}"
-SRC_URI_append = " file://X.service \
- "
-
-# If we don't have mesa-dri as virtual/gl we deactivate this support in xserver and
-# remove remove xorg-extension-glx from RDEPENDS as we user OPENGLES and EGL
-python () {
- if ((d.getVar("PREFERRED_PROVIDER_virtual/libgl", True) or "").find("mesa-dri") == -1):
- extraoeconf = d.getVar("EXTRA_OECONF", True)
- extraoeconf += " --disable-glx --disable-dri"
- d.setVar('EXTRA_OECONF', extraoeconf)
- else:
- d.setVar('RDEPENDS_xserver-xorg', "xserver-xorg-extension-glx")
-}
-
-do_install_append() {
- install -d ${D}/lib/systemd/system
- install -m 0755 ${WORKDIR}/X.service ${D}/lib/systemd/system
-}
-
-FILES_${PN} += "/lib/systemd/system"
-
-WARN_QA = "ldflags useless-rpaths rpaths staticdev"
+LIB_DEPS := "${@oe_filter_out('mesa-dri', '${LIB_DEPS}', d)}"
+LIB_DEPS += "virtual/libgl"
+
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+SRC_URI_append = " file://X.service \
+ "
+
+# If we don't have mesa-dri as virtual/gl we deactivate this support in xserver and
+# remove remove xorg-extension-glx from RDEPENDS as we user OPENGLES and EGL
+python () {
+ if ((d.getVar("PREFERRED_PROVIDER_virtual/libgl", True) or "").find("mesa-dri") == -1):
+ extraoeconf = d.getVar("EXTRA_OECONF", True)
+ extraoeconf += " --disable-glx --disable-dri"
+ d.setVar('EXTRA_OECONF', extraoeconf)
+ else:
+ d.setVar('RDEPENDS_xserver-xorg', "xserver-xorg-extension-glx")
+}
+
+do_install_append() {
+ install -d ${D}/lib/systemd/system
+ install -m 0755 ${WORKDIR}/X.service ${D}/lib/systemd/system
+}
+
+FILES_${PN} += "/lib/systemd/system"
+
+WARN_QA = "ldflags useless-rpaths rpaths staticdev"