aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb')
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb
new file mode 100644
index 0000000..40dcaf4
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb
@@ -0,0 +1,49 @@
+#
+# Contains changes by Wind River Systems, 2013-08-08
+# Copyright (c) 2013 Wind River Systems, Inc.
+# Copyright (C) 2007 OpenedHand Ltd.
+#
+# derived from oe-core: meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+
+SUMMARY = "Minimal boot requirements"
+DESCRIPTION = "The minimal set of packages required to boot the system"
+LICENSE = "MIT"
+DEPENDS = "virtual/kernel"
+PR = "r11"
+
+inherit packagegroup
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#
+# Set by the machine configuration with packages essential for device bootup
+#
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+
+# Distro can override the following VIRTUAL-RUNTIME providers:
+VIRTUAL-RUNTIME_dev_manager ?= "udev"
+VIRTUAL-RUNTIME_login_manager ?= "busybox"
+VIRTUAL-RUNTIME_init_manager ?= "systemd"
+VIRTUAL-RUNTIME_initscripts ?= ""
+VIRTUAL-RUNTIME_keymaps ?= "keymaps"
+
+RDEPENDS_${PN} = "\
+ base-files \
+ base-passwd \
+ busybox \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
+ netbase \
+ ${VIRTUAL-RUNTIME_login_manager} \
+ ${VIRTUAL-RUNTIME_init_manager} \
+ ${VIRTUAL-RUNTIME_initscripts} \
+ ${VIRTUAL-RUNTIME_dev_manager} \
+ ${VIRTUAL-RUNTIME_update-alternatives} \
+ ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
+ kmod \
+ procps \
+ util-linux-mount \
+ "
+
+RRECOMMENDS_${PN} = "\
+ ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"