aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb')
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb
new file mode 100644
index 0000000..f092fe2
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GENIVI P1 Abstract components (AC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-abstract-component-p1 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ bluez5 \
+ bluez5-obex \
+ eglibc \
+ ofono \
+ wayland-ivi-extension \
+ weston \
+ "