aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch')
-rw-r--r--meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
new file mode 100644
index 0000000..45a2deb
--- /dev/null
+++ b/meta-ivi/recipes-extended/dlt-daemon/dlt-daemon/0001-Fix-build-with-systemd-209.patch
@@ -0,0 +1,29 @@
+From 5ec45ad3942e55d83fd0b13ef4bafa39a54e0578 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Erik=20Bot=C3=B6?= <erik.boto@pelagicore.com>
+Date: Fri, 4 Apr 2014 10:59:18 +0200
+Subject: [PATCH] Fix build with systemd >= 209
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Erik Botö <erik.boto@pelagicore.com>
+---
+ src/system/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
+index d78b2e9..b04e54b 100644
+--- a/src/system/CMakeLists.txt
++++ b/src/system/CMakeLists.txt
+@@ -23,7 +23,7 @@ set(dlt_system_SRCS dlt-system.c dlt-system-options.c dlt-system-process-handlin
+ dlt-system-syslog.c dlt-system-watchdog.c dlt-system-journal.c)
+ add_executable(dlt-system ${dlt_system_SRCS} ${systemd_SRCS})
+ if(WITH_SYSTEMD_JOURNAL)
+- target_link_libraries(dlt-system dlt z systemd-journal systemd-id128)
++ target_link_libraries(dlt-system dlt z systemd)
+ else(WITH_SYSTEMD_JOURNAL)
+ target_link_libraries(dlt-system dlt z)
+ endif(WITH_SYSTEMD_JOURNAL)
+--
+1.9.1
+