aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend')
-rw-r--r--meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend b/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
new file mode 100644
index 0000000..8b50f89
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
@@ -0,0 +1,26 @@
+#
+# for test
+#
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+SRC_URI_append += " \
+ file://0001-change-file-position-for-dlt-test-filetransfer.patch \
+ "
+
+EXTRA_OECMAKE += "-DWITH_DLTTEST=ON -DCMAKE_SKIP_RPATH=ON -DWITH_MAN=OFF"
+
+do_install_append() {
+ _BIN=${WORKDIR}/build/src/tests
+ install -d ${D}/opt/tests/${PN}/data
+ install -m 0755 ${_BIN}/dlt-test-* ${D}/opt/tests/${PN}
+}
+
+PACKAGES += "${PN}-test"
+DEPENDS_${PN}-test = "${PN}"
+
+FILES_${PN}-dbg += " \
+ /opt/tests/${PN}/.debug/* \
+ "
+FILES_${PN}-test = " \
+ /opt/tests/${PN}/dlt-test* \
+ /opt/tests/${PN}/data/* \
+ "