aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch24
-rw-r--r--meta-ivi/recipes-connectivity/bluez5/bluez5/0025-core-Make-device_get_path-public.patch33
2 files changed, 36 insertions, 21 deletions
diff --git a/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch b/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
index 9affbbe..08a8651 100644
--- a/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
+++ b/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
@@ -1,4 +1,4 @@
-From 5b444f8930a2635d52a676f0600e80828cc876c9 Mon Sep 17 00:00:00 2001
+From 44c5dc231eb4ad036356d717c9948701227a673f Mon Sep 17 00:00:00 2001
From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
Date: Sun, 5 Jan 2014 18:02:56 +0200
Subject: [PATCH 01/12] plugins: Add initial code for service plugin
@@ -12,10 +12,10 @@ This plugin will be used to control services individually.
create mode 100644 plugins/service.c
diff --git a/Makefile.plugins b/Makefile.plugins
-index f0eada9..3ab27e2 100644
+index 3ab7c1c18..8c707252e 100644
--- a/Makefile.plugins
+++ b/Makefile.plugins
-@@ -119,3 +119,11 @@ plugins_sixaxis_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
+@@ -110,3 +110,11 @@ plugins_sixaxis_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-no-undefined @UDEV_LIBS@
plugins_sixaxis_la_CFLAGS = $(AM_CFLAGS) -fvisibility=hidden @UDEV_CFLAGS@
endif
@@ -24,14 +24,14 @@ index f0eada9..3ab27e2 100644
+plugin_LTLIBRARIES += plugins/service.la
+plugins_service_la_SOURCES = plugins/service.c
+plugins_service_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-+ -no-undefined
++ -no-undefined
+plugins_service_la_CFLAGS = $(AM_CFLAGS) -fvisibility=hidden
+endif
diff --git a/configure.ac b/configure.ac
-index d858ff6..6d31dd3 100644
+index ec810fcf4..173b7f834 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -221,6 +221,10 @@ AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
+@@ -328,6 +328,10 @@ AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
AM_CONDITIONAL(SIXAXIS, test "${enable_sixaxis}" = "yes" &&
test "${enable_udev}" != "no")
@@ -39,12 +39,12 @@ index d858ff6..6d31dd3 100644
+ [enable service plugin]), [enable_service=${enableval}])
+AM_CONDITIONAL(SERVICE, test "${enable_service}" = "yes")
+
- if (test "${prefix}" = "NONE"); then
- dnl no prefix and no localstatedir, so default to /var
- if (test "$localstatedir" = '${prefix}/var'); then
+ AC_ARG_ENABLE(logger, AC_HELP_STRING([--enable-logger],
+ [enable HCI logger service]), [enable_logger=${enableval}])
+ AM_CONDITIONAL(LOGGER, test "${enable_logger}" = "yes")
diff --git a/plugins/service.c b/plugins/service.c
new file mode 100644
-index 0000000..e63d8a8
+index 000000000..3a236dffe
--- /dev/null
+++ b/plugins/service.c
@@ -0,0 +1,44 @@
@@ -91,7 +91,7 @@ index 0000000..e63d8a8
+}
+
+BLUETOOTH_PLUGIN_DEFINE(service, VERSION, BLUETOOTH_PLUGIN_PRIORITY_DEFAULT,
-+ service_init, service_exit)
++ service_init, service_exit)
--
-2.2.0
+2.17.1
diff --git a/meta-ivi/recipes-connectivity/bluez5/bluez5/0025-core-Make-device_get_path-public.patch b/meta-ivi/recipes-connectivity/bluez5/bluez5/0025-core-Make-device_get_path-public.patch
index a0eb0bc..baa86ae 100644
--- a/meta-ivi/recipes-connectivity/bluez5/bluez5/0025-core-Make-device_get_path-public.patch
+++ b/meta-ivi/recipes-connectivity/bluez5/bluez5/0025-core-Make-device_get_path-public.patch
@@ -1,7 +1,18 @@
-diff -ur bluez-5.48.bak/src/device.c bluez-5.48/src/device.c
---- bluez-5.48.bak/src/device.c 2018-08-20 14:34:33.895522420 +0200
-+++ bluez-5.48/src/device.c 2018-08-20 14:35:13.699483187 +0200
-@@ -5219,6 +5219,10 @@
+From 54118063c549e72271c55abab753a02e4bb77a79 Mon Sep 17 00:00:00 2001
+From: Yong-iL Joh <yong-il.joh@windriver.com>
+Date: Mon, 27 Aug 2018 13:46:10 +0200
+Subject: [PATCH 25/25] core: Make device get path public
+
+---
+ src/device.c | 4 ++++
+ src/device.h | 1 +
+ 2 files changed, 5 insertions(+)
+
+diff --git a/src/device.c b/src/device.c
+index ef5b8f86a..12d5aed63 100644
+--- a/src/device.c
++++ b/src/device.c
+@@ -5328,6 +5328,10 @@ const char *device_get_path(const struct btd_device *device)
return device->path;
}
@@ -12,14 +23,18 @@ diff -ur bluez-5.48.bak/src/device.c bluez-5.48/src/device.c
gboolean device_is_temporary(struct btd_device *device)
{
return device->temporary;
-diff -ur bluez-5.48.bak/src/device.h bluez-5.48/src/device.h
---- bluez-5.48.bak/src/device.h 2018-08-20 14:34:33.895522420 +0200
-+++ bluez-5.48/src/device.h 2018-08-20 14:35:13.699483187 +0200
-@@ -88,6 +88,7 @@
- struct btd_adapter *device_get_adapter(struct btd_device *device);
+diff --git a/src/device.h b/src/device.h
+index 06b100499..38337f07b 100644
+--- a/src/device.h
++++ b/src/device.h
+@@ -91,6 +91,7 @@ struct btd_adapter *device_get_adapter(struct btd_device *device);
const bdaddr_t *device_get_address(struct btd_device *device);
+ uint8_t device_get_le_address_type(struct btd_device *device);
const char *device_get_path(const struct btd_device *device);
+const char *btd_device_get_path(const struct btd_device *device);
gboolean device_is_temporary(struct btd_device *device);
bool device_is_connectable(struct btd_device *device);
bool device_is_paired(struct btd_device *device, uint8_t bdaddr_type);
+--
+2.17.1
+