aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg4
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg4
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg4
-rw-r--r--recipes-core-ivi/dbus/dbus_1.6.18.bbappend5
-rw-r--r--recipes-core-ivi/eglibc/eglibc_2.19.bbappend17
5 files changed, 22 insertions, 12 deletions
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg
index b63e70e..0bdcbeb 100644
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86.cfg
@@ -3,8 +3,8 @@ CONFIG_MEDIA_SUPPORT=y
CONFIG_MEDIA_CONTROLLER=y
# config for adding support for AF_BUS sockets
-CONFIG_AF_BUS=y
-CONFIG_NETFILTER_DBUS=y
+# CONFIG_AF_BUS is not set
+# CONFIG_NETFILTER_DBUS is not set
# Activate ecryptfs
CONFIG_EXPERIMENTAL=y
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg
index b63e70e..0bdcbeb 100644
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/qemux86_64.cfg
@@ -3,8 +3,8 @@ CONFIG_MEDIA_SUPPORT=y
CONFIG_MEDIA_CONTROLLER=y
# config for adding support for AF_BUS sockets
-CONFIG_AF_BUS=y
-CONFIG_NETFILTER_DBUS=y
+# CONFIG_AF_BUS is not set
+# CONFIG_NETFILTER_DBUS is not set
# Activate ecryptfs
CONFIG_EXPERIMENTAL=y
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
index 1f09dae..e472489 100644
--- a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
@@ -831,8 +831,8 @@ CONFIG_MEDIA_SUPPORT=y
CONFIG_MEDIA_CONTROLLER=y
# config for adding support for AF_BUS sockets
-CONFIG_AF_BUS=y
-CONFIG_NETFILTER_DBUS=y
+# CONFIG_AF_BUS is not set
+# CONFIG_NETFILTER_DBUS is not set
CONFIG_REGULATOR=n
diff --git a/recipes-core-ivi/dbus/dbus_1.6.18.bbappend b/recipes-core-ivi/dbus/dbus_1.6.18.bbappend
index 0e73a50..ea9b79d 100644
--- a/recipes-core-ivi/dbus/dbus_1.6.18.bbappend
+++ b/recipes-core-ivi/dbus/dbus_1.6.18.bbappend
@@ -3,7 +3,10 @@ PRINC := "${@int(PRINC) + 3}"
# add support for GENIVI AF_Bus D-Bus Optimization
# - http://projects.genivi.org/afbus-dbus-optimization/
-SRC_URI_AFBUS = "file://dbus_1.6-add-afbus-support.patch"
+SRC_URI_AFBUS = ""
+# currently disabled in preparation of the move to kdbus
+# uncomment the next line to reenable
+#SRC_URI_AFBUS = "file://dbus_1.6-add-afbus-support.patch"
# add support for GENIVI CommonAPI D-Bus runtime
# - http://projects.genivi.org/commonapi/
diff --git a/recipes-core-ivi/eglibc/eglibc_2.19.bbappend b/recipes-core-ivi/eglibc/eglibc_2.19.bbappend
index 547fdb8..8a94c7a 100644
--- a/recipes-core-ivi/eglibc/eglibc_2.19.bbappend
+++ b/recipes-core-ivi/eglibc/eglibc_2.19.bbappend
@@ -1,9 +1,16 @@
# Use local $PN directory
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
+
+# add support for GENIVI AF_Bus D-Bus Optimization
+# - http://projects.genivi.org/afbus-dbus-optimization/
+SRC_URI_AFBUS = ""
+# currently disabled in preparation of the move to kdbus
+# uncomment the next line to reenable
+#SRC_URI_AFBUS = "file://eglibc_2.18_add_af_bus_support.patch"
+
+SRC_URI_append = "\
+ ${SRC_URI_AFBUS} \
+"
-# Add patch to avoid overwriting libc_cv_rootsbindir
-SRC_URI += " \
- file://eglibc_2.18_add_af_bus_support.patch \
- "