summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch30
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb5
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch28
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb5
4 files changed, 66 insertions, 2 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch
new file mode 100644
index 0000000..49abf35
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/fix-with-automake-1-15.patch
@@ -0,0 +1,30 @@
+Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
+issues with automake 1.15.
+
+https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
+https://bugzilla.redhat.com/show_bug.cgi?id=1179182
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=353]
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -4,12 +4,14 @@ AC_INIT([GENIVI IPC Common API DBus C++]
+ [],
+ [CommonAPI-DBus])
+
++AC_CONFIG_AUX_DIR([build-aux])
++AC_CONFIG_HEADERS([build-aux/config.h])
++
+ AC_USE_SYSTEM_EXTENSIONS
+
+ AC_CONFIG_MACRO_DIR([m4])
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+-AC_CONFIG_AUX_DIR([build-aux])
+-AC_CONFIG_HEADERS([build-aux/config.h])
++
+ AC_CONFIG_FILES([
+ Makefile
+ CommonAPI-DBus.pc
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
index d1d612f..34b3071 100644
--- a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus_2.1.6-p6.bb
@@ -5,7 +5,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
BRANCH ?= "maintain/2.1.6"
TAG ?= "${PV}"
-SRC_URI = "git://git.projects.genivi.org/ipc/common-api-dbus-runtime.git;branch=${BRANCH};tag=${TAG}"
+SRC_URI = " \
+ git://git.projects.genivi.org/ipc/common-api-dbus-runtime.git;branch=${BRANCH};tag=${TAG} \
+ file://fix-with-automake-1-15.patch \
+ "
S = "${WORKDIR}/git"
DEPENDS = "common-api2 dbus"
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
new file mode 100644
index 0000000..1c5eaab
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
@@ -0,0 +1,28 @@
+Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
+issues with automake 1.15.
+
+https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
+https://bugzilla.redhat.com/show_bug.cgi?id=1179182
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=352]
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -4,10 +4,12 @@ AC_INIT([GENIVI IPC Common API C++],
+ [],
+ [CommonAPI])
+
+-AC_CONFIG_MACRO_DIR([m4])
+-m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AC_CONFIG_HEADERS([build-aux/config.h])
++
++AC_CONFIG_MACRO_DIR([m4])
++m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
++
+ AC_CONFIG_FILES([
+ Makefile
+ CommonAPI.pc
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb b/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
index 19a3b7a..5608bc4 100644
--- a/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
@@ -6,7 +6,10 @@ PROVIDES = "common-api2"
BRANCH ?= "maintain/2.1.6"
TAG ?= "${PV}"
-SRC_URI = "git://git.projects.genivi.org/ipc/common-api-runtime.git;branch=${BRANCH};tag=${TAG}"
+SRC_URI = " \
+ git://git.projects.genivi.org/ipc/common-api-runtime.git;branch=${BRANCH};tag=${TAG} \
+ file://fix-with-automake-1-15.patch \
+ "
S = "${WORKDIR}/git"
CXXFLAGS := "${@oe_filter_out('-fvisibility-inlines-hidden', '${CXXFLAGS}', d)}"