summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch28
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb17
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++_3.1.3.bb20
3 files changed, 20 insertions, 45 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
deleted file mode 100644
index 1c5eaab..0000000
--- a/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
-issues with automake 1.15.
-
-https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
-https://bugzilla.redhat.com/show_bug.cgi?id=1179182
-
-Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
-Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=352]
-
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac
-+++ git/configure.ac
-@@ -4,10 +4,12 @@ AC_INIT([GENIVI IPC Common API C++],
- [],
- [CommonAPI])
-
--AC_CONFIG_MACRO_DIR([m4])
--m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
- AC_CONFIG_AUX_DIR([build-aux])
- AC_CONFIG_HEADERS([build-aux/config.h])
-+
-+AC_CONFIG_MACRO_DIR([m4])
-+m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-+
- AC_CONFIG_FILES([
- Makefile
- CommonAPI.pc
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb b/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
deleted file mode 100644
index 5608bc4..0000000
--- a/meta-ivi/recipes-extended/common-api/common-api-c++_2.1.6-p1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "CommonAPI"
-SECTION = "libs"
-LICENSE = "MPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
-PROVIDES = "common-api2"
-
-BRANCH ?= "maintain/2.1.6"
-TAG ?= "${PV}"
-SRC_URI = " \
- git://git.projects.genivi.org/ipc/common-api-runtime.git;branch=${BRANCH};tag=${TAG} \
- file://fix-with-automake-1-15.patch \
- "
-S = "${WORKDIR}/git"
-
-CXXFLAGS := "${@oe_filter_out('-fvisibility-inlines-hidden', '${CXXFLAGS}', d)}"
-
-inherit autotools lib_package pkgconfig
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.3.bb b/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.3.bb
new file mode 100644
index 0000000..064499d
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.3.bb
@@ -0,0 +1,20 @@
+SUMMARY = "CommonAPI"
+SECTION = "libs"
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+PROVIDES = "commonapi3"
+PR = "r1"
+
+inherit autotools cmake lib_package pkgconfig
+
+SRC_URI = "git://git.projects.genivi.org/ipc/common-api-runtime.git;branch=master;tag=${PV}"
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE += "-DCMAKE_INSTALL_PREFIX=/usr"
+
+do_configure_prepend () {
+ sed -i '/ set(${var} /c set(ABSOLUTE_${var} "${CMAKE_INSTALL_PREFIX}/${${var}}") ' ${S}/CMakeLists.txt
+ sed -i '/file(RELATIVE_PATH /c file(RELATIVE_PATH REL_INCLUDE_DIR "${ABSOLUTE_INSTALL_CMAKE_DIR}" "${ABSOLUTE_INSTALL_INCLUDE_DIR}") ' ${S}/CMakeLists.txt
+}
+
+FILES_${PN}-dev += "${libdir}/cmake"