aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md4
-rw-r--r--recipes-devtools/qemu/qemu-2012.04/dummy-gl-config.patch34
-rw-r--r--recipes-devtools/qemu/qemu-2012.04/fallback-to-safe-mmap_min_addr.patch39
-rw-r--r--recipes-devtools/qemu/qemu-2012.04/larger_default_ram_size.patch22
-rw-r--r--recipes-devtools/qemu/qemu-2012.04/no-strip.patch19
-rw-r--r--recipes-devtools/qemu/qemu-2012.04/powerpc_rom.binbin4096 -> 0 bytes
-rw-r--r--recipes-devtools/qemu/qemu_2012.04.bb32
7 files changed, 4 insertions, 146 deletions
diff --git a/README.md b/README.md
index 14efad9..43ab8ee 100644
--- a/README.md
+++ b/README.md
@@ -60,4 +60,8 @@ You can build a QEMU image including GENIVI P1 components using the following st
14. Run the emulator:
+ for qemu vexpressa9:
$ PATH_TO_META_IVI/meta-ivi/scripts/runqemu excalibur-image vexpressa9
+
+ for qemux86:
+ $ PATH_TO_POKY/poky/scripts/runqemu excalibur-image qemux86
diff --git a/recipes-devtools/qemu/qemu-2012.04/dummy-gl-config.patch b/recipes-devtools/qemu/qemu-2012.04/dummy-gl-config.patch
deleted file mode 100644
index c4a76bd..0000000
--- a/recipes-devtools/qemu/qemu-2012.04/dummy-gl-config.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Add a dummy option for GL acceleration to pass the configure when there is no
-GL acceleration patch. The parsing function will be filled by following
-opengl-disable-option.patch.
-Upstream-Status: Inappropriate [other] - depends on GL patch
-
-Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
-
-Patch rewritten for this qemu version
-
-Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
-
-Index: git/configure
-===================================================================
---- git.orig/configure 2012-05-31 10:59:40.757440002 +0300
-+++ git/configure 2012-05-31 11:01:43.901435595 +0300
-@@ -191,6 +191,7 @@
- smartcard_nss=""
- usb_redir=""
- opengl=""
-+gl_accel="yes"
- zlib="yes"
- guest_agent="yes"
- libiscsi=""
-@@ -812,6 +811,10 @@
- ;;
- --enable-opengl) opengl="yes"
- ;;
-+ --disable-gl-accel) gl_accel="no"
-+ ;;
-+ --enable-gl-accel) gl_accel="yes"
-+ ;;
- --disable-rbd) rbd="no"
- ;;
- --enable-rbd) rbd="yes"
diff --git a/recipes-devtools/qemu/qemu-2012.04/fallback-to-safe-mmap_min_addr.patch b/recipes-devtools/qemu/qemu-2012.04/fallback-to-safe-mmap_min_addr.patch
deleted file mode 100644
index 2075386..0000000
--- a/recipes-devtools/qemu/qemu-2012.04/fallback-to-safe-mmap_min_addr.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From c313f89c33217ac0e471554dace2144718f86669 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Thu, 13 May 2010 12:23:40 +0200
-Subject: [PATCH] linux-user: use default mmap_min_addr 65536 when /proc/sys/vm/mmap_min_addr cannot be read
-
-* 65536 is default at least for ubuntu and fedora.
----
- linux-user/main.c | 5 +++++
- 1 files changed, 5 insertions(+), 0 deletions(-)
-
-Upstream-Status: Pending
-
-Index: qemu-0.14.0/linux-user/main.c
-===================================================================
---- qemu-0.14.0.orig/linux-user/main.c
-+++ qemu-0.14.0/linux-user/main.c
-@@ -36,6 +36,7 @@
- #include "envlist.h"
-
- #define DEBUG_LOGFILE "/tmp/qemu.log"
-+#define MMAP_MIN_ADDR_DEFAULT 65536
-
- char *exec_path;
-
-@@ -3010,8 +3011,14 @@ int main(int argc, char **argv, char **e
- if (fscanf(fp, "%lu", &tmp) == 1) {
- mmap_min_addr = tmp;
- qemu_log("host mmap_min_addr=0x%lx\n", mmap_min_addr);
-+ } else {
-+ qemu_log("cannot read value from /proc/sys/vm/mmap_min_addr, assuming %d\n", MMAP_MIN_ADDR_DEFAULT);
-+ mmap_min_addr = MMAP_MIN_ADDR_DEFAULT;
- }
- fclose(fp);
-+ } else {
-+ qemu_log("cannot open /proc/sys/vm/mmap_min_addr for reading, assuming %d\n", MMAP_MIN_ADDR_DEFAULT);
-+ mmap_min_addr = MMAP_MIN_ADDR_DEFAULT;
- }
- }
-
diff --git a/recipes-devtools/qemu/qemu-2012.04/larger_default_ram_size.patch b/recipes-devtools/qemu/qemu-2012.04/larger_default_ram_size.patch
deleted file mode 100644
index 711c360..0000000
--- a/recipes-devtools/qemu/qemu-2012.04/larger_default_ram_size.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-This patch is taken from debian. 128M is too less sometimes if distro
-with lot of packages is booted so this patch raises the default to 384M
-
-It has not been applied to upstream qemu
-
-Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-Index: qemu-0.14.0/vl.c
-===================================================================
---- qemu-0.14.0.orig/vl.c
-+++ qemu-0.14.0/vl.c
-@@ -168,7 +168,7 @@ int main(int argc, char **argv)
- //#define DEBUG_NET
- //#define DEBUG_SLIRP
-
--#define DEFAULT_RAM_SIZE 128
-+#define DEFAULT_RAM_SIZE 384
-
- #define MAX_VIRTIO_CONSOLES 1
-
diff --git a/recipes-devtools/qemu/qemu-2012.04/no-strip.patch b/recipes-devtools/qemu/qemu-2012.04/no-strip.patch
deleted file mode 100644
index f5ada7e..0000000
--- a/recipes-devtools/qemu/qemu-2012.04/no-strip.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
-
----
- Makefile | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index ffd3364..38d8352 100644
---- a/Makefile
-+++ b/Makefile
-@@ -288,7 +288,7 @@ install-sysconfig:
- install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
- $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
- ifneq ($(TOOLS),)
-- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
-+ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
- endif
- ifneq ($(BLOBS),)
- $(INSTALL_DIR) "$(DESTDIR)$(datadir)"
diff --git a/recipes-devtools/qemu/qemu-2012.04/powerpc_rom.bin b/recipes-devtools/qemu/qemu-2012.04/powerpc_rom.bin
deleted file mode 100644
index c404429..0000000
--- a/recipes-devtools/qemu/qemu-2012.04/powerpc_rom.bin
+++ /dev/null
Binary files differ
diff --git a/recipes-devtools/qemu/qemu_2012.04.bb b/recipes-devtools/qemu/qemu_2012.04.bb
deleted file mode 100644
index 82b73e4..0000000
--- a/recipes-devtools/qemu/qemu_2012.04.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-require recipes-devtools/qemu/qemu.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
- file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
-
-PR = "r2"
-
-FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
-FILESDIR = "${WORKDIR}"
-
-# Tag 2012.04
-SRCREV = "cc9364d58d474ee6ebc78d98ad3f24afe65b95a6"
-
-SRC_URI = "\
- git://git.linaro.org/qemu/qemu-linaro.git;protocol=git \
- file://powerpc_rom.bin \
- file://no-strip.patch \
- file://fallback-to-safe-mmap_min_addr.patch \
- file://larger_default_ram_size.patch \
- file://dummy-gl-config.patch \
- "
-# Only use the GL passthrough patches for native/nativesdk versions
-QEMUGLPATCHES = "\
- "
-SRC_URI_append_virtclass-native = "\
- ${QEMUGLPATCHES} \
- "
-
-SRC_URI_append_virtclass-nativesdk = "\
- ${QEMUGLPATCHES} \
- "
-S = "${WORKDIR}/git" \ No newline at end of file