aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_5.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_5.10.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
new file mode 100644
index 00000000..d3ee342c
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -0,0 +1,25 @@
+require linux-intel.inc
+
+# Skip processing of this recipe if it is not explicitly specified as the
+# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
+# to build multiple virtual/kernel providers, e.g. as dependency of
+# core-image-rt-sdk, core-image-rt.
+python () {
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
+}
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
+"
+
+KBRANCH = "5.10/preempt-rt"
+KMETA_BRANCH = "yocto-5.10"
+
+DEPENDS += "elfutils-native openssl-native util-linux-native"
+
+LINUX_VERSION ?= "5.10.1"
+SRCREV_machine ?= "7cc9ab35ca5c12de2484deeb2ffe0ebc063e409a"
+SRCREV_meta ?= "30c21625f9989859ade341ebe738664f3efbf122"
+
+LINUX_KERNEL_TYPE = "preempt-rt"