aboutsummaryrefslogtreecommitdiffstats
path: root/meta-crystalforest/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-crystalforest/conf')
-rw-r--r--meta-crystalforest/conf/layer.conf12
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-shumway.conf26
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-stargo.conf27
3 files changed, 65 insertions, 0 deletions
diff --git a/meta-crystalforest/conf/layer.conf b/meta-crystalforest/conf/layer.conf
new file mode 100644
index 00000000..6b802d63
--- /dev/null
+++ b/meta-crystalforest/conf/layer.conf
@@ -0,0 +1,12 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "crystalforest"
+BBFILE_PATTERN_crystalforest := "^${LAYERDIR}/"
+BBFILE_PRIORITY_crystalforest = "6"
+
+LAYERDEPENDS_crystalforest = "intel"
diff --git a/meta-crystalforest/conf/machine/crystalforest-shumway.conf b/meta-crystalforest/conf/machine/crystalforest-shumway.conf
new file mode 100644
index 00000000..0a2141c8
--- /dev/null
+++ b/meta-crystalforest/conf/machine/crystalforest-shumway.conf
@@ -0,0 +1,26 @@
+#@TYPE: Machine
+#@NAME: crystalforest-shumway
+
+#@DESCRIPTION: Machine configuration for Crystal Forest Server (SHUMWAY) systems
+# i.e. Two Sandy Bridge Jaketown processors (SNB-EP ES2 Grade and SNB-EN ES2 Grade) + Two Cave Creek Chipsets.
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "3.4%"
+
+require conf/machine/include/tune-x86_64.inc
+require conf/machine/include/ia32-base.inc
+require conf/machine/include/meta-intel.inc
+
+XSERVER ?= "${XSERVER_IA32_BASE} \
+ ${XSERVER_IA32_EXT} \
+ ${XSERVER_IA32_MATROX_MGA} \
+ "
+#This Kernel Option is required for Intel Quick Assist Technology Software.
+APPEND += "acpi_enforce_resources=lax"
+
+#Uncomment the below Kernel Option if Virtualization is not needed.
+#APPEND += "intel_iommu=off"
+
+SYSLINUX_OPTS = "serial 0 115200"
+SERIAL_CONSOLE = "115200 ttyS0"
+APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-crystalforest/conf/machine/crystalforest-stargo.conf b/meta-crystalforest/conf/machine/crystalforest-stargo.conf
new file mode 100644
index 00000000..575a504d
--- /dev/null
+++ b/meta-crystalforest/conf/machine/crystalforest-stargo.conf
@@ -0,0 +1,27 @@
+#@TYPE: Machine
+#@NAME: crystalforest-stargo
+
+#@DESCRIPTION: Machine configuration for Crystal Forest (STARGO) systems
+# i.e. One Sandy Bridge based Gladden Processor + One Cave Creek Chipset
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "3.4%"
+
+require conf/machine/include/tune-x86_64.inc
+require conf/machine/include/ia32-base.inc
+require conf/machine/include/meta-intel.inc
+
+XSERVER ?= "${XSERVER_IA32_BASE} \
+ ${XSERVER_IA32_EXT} \
+ ${XSERVER_IA32_MATROX_MGA} \
+ "
+
+#This Kernel Option is required for Intel Quick Assist Technology Software.
+APPEND += "acpi_enforce_resources=lax"
+
+#Uncomment the below Kernel Option if Virtualization is not needed.
+#APPEND += "intel_iommu=off"
+
+SYSLINUX_OPTS = "serial 0 115200"
+SERIAL_CONSOLE = "115200 ttyS0"
+APPEND += "console=ttyS0,115200 console=tty0"