aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb16
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb6
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb16
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb6
4 files changed, 32 insertions, 12 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
index 7d67fb0a..361b5dfc 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -18,8 +18,18 @@ KMETA_BRANCH = "yocto-5.10"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.10.21"
-SRCREV_machine ?= "774cd893ee3f4044305e0a7bf5090e32b72578b3"
-SRCREV_meta ?= "eb09284047fec2f09d62068c338ae320c6681bd1"
+LINUX_VERSION ?= "5.10.30"
+SRCREV_machine ?= "8b07bfbd844f73cbedc1f8eaa63e8b79295745d8"
+SRCREV_meta ?= "cd049697e9b2d3e9118110d476075ff8f87202cc"
LINUX_KERNEL_TYPE = "preempt-rt"
+
+# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
+# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
+# In which 'CONFIG_DRM_GMA3600' config option is dropped.
+# This causes warning during config audit. So suppress the harmless warning for now.
+KCONF_BSP_AUDIT_LEVEL = "0"
+
+# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
+# causes config warning too.
+KCONF_AUDIT_LEVEL_core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
index f26a5127..2ec2a002 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -18,9 +18,9 @@ KMETA_BRANCH = "yocto-5.4"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.4.93"
-SRCREV_machine ?= "6d57e4c1caf4b50e55d27251a39312fec10cd870"
-SRCREV_meta ?= "4f6d6c23cc8ca5d9c39b1efc2619b1dfec1ef2bc"
+LINUX_VERSION ?= "5.4.115"
+SRCREV_machine ?= "00c7e2e1841e0ed3c1249c0e4bcacbd70435d62e"
+SRCREV_meta ?= "9e2546ab8d63f70ba458eb159d29ce6736ffd3e4"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
index 399ab014..dae4118a 100644
--- a/recipes-kernel/linux/linux-intel_5.10.bb
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -10,9 +10,9 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.10.25"
-SRCREV_machine ?= "7c8f517558810be0c9470f78a06f9c8b909157b4"
-SRCREV_meta ?= "eb09284047fec2f09d62068c338ae320c6681bd1"
+LINUX_VERSION ?= "5.10.41"
+SRCREV_machine ?= "916ac934a98bc8206c1b5e1500c891dbcb43aac7"
+SRCREV_meta ?= "cd049697e9b2d3e9118110d476075ff8f87202cc"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
@@ -20,3 +20,13 @@ KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
# Functionality flags
KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
+
+# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
+# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
+# In which 'CONFIG_DRM_GMA3600' config option is dropped.
+# This causes warning during config audit. So suppress the harmless warning for now.
+KCONF_BSP_AUDIT_LEVEL = "0"
+
+# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
+# causes config warning too.
+KCONF_AUDIT_LEVEL_core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
index 5b8a4457..910b0cfd 100644
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ b/recipes-kernel/linux/linux-intel_5.4.bb
@@ -9,9 +9,9 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "5.4.106"
-SRCREV_machine ?= "4dbe3697c9b89500917d5b6ff3a42b7af769de00"
-SRCREV_meta ?= "19738ca97b999a3b150e2d34232bb44b6537348f"
+LINUX_VERSION ?= "5.4.115"
+SRCREV_machine ?= "2521f747baec6ccd170456c0fe697c48844a080d"
+SRCREV_meta ?= "9e2546ab8d63f70ba458eb159d29ce6736ffd3e4"
# For Crystalforest and Romley
KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"