aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc12
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb17
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb12
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb12
4 files changed, 36 insertions, 17 deletions
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
index d9032b2..0a53900 100644
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
@@ -43,6 +43,18 @@ PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \
libwayland-egl-mx6-dev \
"
+# Skip package if it does not match the machine float-point type in use
+python __anonymous () {
+ is_machine_hardfp = base_contains("TUNE_FEATURES", "callconvention-hard", True, False, d)
+ is_package_hardfp = d.getVar("PACKAGE_FP_TYPE", True) == "hardfp"
+
+ if is_package_hardfp != is_machine_hardfp:
+ PN = d.getVar("PN", True)
+ PV = d.getVar("PV", True)
+ bb.debug(1, "Skipping %s (%s) as machine and package float-point does not match" % (PN, PV))
+ raise bb.parse.SkipPackage("Package Float-Point is not compatible with the machine")
+}
+
USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}"
USE_DFB = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}"
USE_WL = "${@base_contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb
deleted file mode 100644
index d8e00ef..0000000
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright (C) 2012-2013 Freescale Semiconductor
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-PR = "r5.0"
-
-include gpu-viv-bin-mx6q.inc
-
-SRC_URI += "file://0001-change-header-path-to-HAL.patch \
- file://gc_hal_eglplatform-remove-xlib-undefs.patch \
- file://fix-conflicting-TLS-definition.patch"
-
-SRC_URI[md5sum] = "2bb7d2f4bdff79ae99ce0c9fc2540701"
-SRC_URI[sha256sum] = "48d04d11c6fec11411bcd97c47199caea517ebcd86db6c70f1964b3358a68924"
-
-# FIXME: 3.0.35-4.0.0 BSP release uses DirectFB 1.4 and Yocto has 1.6 so
-# disable it for now
-USE_DFB = "no"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb
new file mode 100644
index 0000000..a55e988
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-hfp.bb
@@ -0,0 +1,12 @@
+# Copyright (C) 2013 Freescale Semiconductor
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+include gpu-viv-bin-mx6q.inc
+
+SRC_URI += "file://0001-change-header-path-to-HAL.patch \
+ file://gc_hal_eglplatform-remove-xlib-undefs.patch"
+
+SRC_URI[md5sum] = "f5f4e2e7767c784315461c132929e7d3"
+SRC_URI[sha256sum] = "f16747ee5ae2e88631cc1494db98f7b5762940c7db25795906b7cc8f87405caf"
+
+PACKAGE_FP_TYPE = "hardfp"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb
new file mode 100644
index 0000000..2383fb7
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.5.7-1.0.0-alpha.2-sfp.bb
@@ -0,0 +1,12 @@
+# Copyright (C) 2013 Freescale Semiconductor
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+include gpu-viv-bin-mx6q.inc
+
+SRC_URI += "file://0001-change-header-path-to-HAL.patch \
+ file://gc_hal_eglplatform-remove-xlib-undefs.patch"
+
+SRC_URI[md5sum] = "ef08a4ad04c7886a44af16e826d0f444"
+SRC_URI[sha256sum] = "e212e361044eb1f9089761e115e71b27dab67c832ebb1ddbc830c17d2b1e2fba"
+
+PACKAGE_FP_TYPE = "softfp"