aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc43
-rw-r--r--recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb9
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc
new file mode 100644
index 0000000..a6b7a5e
--- /dev/null
+++ b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc
@@ -0,0 +1,43 @@
+# Copyright (C) 2013 Freescale Semiconductor
+
+DESCRIPTION = "GPU Vivante G2D library and sample applications for imx6"
+SECTION = "libs"
+LICENSE = "Proprietary"
+PROVIDES += "virtual/libg2d"
+
+inherit fsl-eula-unpack
+
+PE = "1"
+
+SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
+
+PACKAGES = "gpu-viv-g2d gpu-viv-g2d-dev gpu-viv-g2d-dbg"
+
+# Inhibit warnings about files being stripped.
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_install () {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+
+ cp ${S}/usr/lib/*.so ${D}${libdir}
+ cp -axr ${S}/usr/include/* ${D}${includedir}
+ cp -axr ${S}/opt ${D}
+
+ find ${D}${libdir} -type f -exec chmod 644 {} \;
+ find ${D}${includedir} -type f -exec chmod 644 {} \;
+}
+
+# FIXME: The provided binary doesn't provide soname. If in future BSP
+# release the libraries are fixed, we can drop this hack.
+REALSOLIBS := "${SOLIBS}"
+SOLIBS = "${SOLIBSDEV}"
+
+FILES_${PN} = "/opt ${libdir}/libg2d${SOLIBS} "
+FILES_${PN}-dev = "${includedir}"
+FILES_${PN}-dbg = "${libdir}/.debug/libg2d${SOLIBS}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx6)"
diff --git a/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb
new file mode 100644
index 0000000..349cb2e
--- /dev/null
+++ b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb
@@ -0,0 +1,9 @@
+# Copyright (C) 2013 Freescale Semiconductor
+
+include gpu-viv-g2d.inc
+
+LIC_FILES_CHKSUM = "file://usr/include/g2d.h;endline=7;md5=861ebad4adc7236f8d1905338abd7eb2"
+
+SRC_URI[md5sum] = "cb1939d1de300bbe334e6e8e0137ae57"
+SRC_URI[sha256sum] = "460d0df171766edbea1fe6781a38346596ad13f748eb971296c04c261cec5450"
+