aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend16
1 files changed, 9 insertions, 7 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 6f9e09d..c062dba 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -1,8 +1,10 @@
-CFLAGS_append_mx6 = " -DLINUX \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
- bb.utils.contains('DISTRO_FEATURES', 'wayland', \
- '-DEGL_API_FB -DEGL_API_WL', '-DEGL_API_FB', d), d)}"
+CFLAGS_append_imxgpu2d = " \
+ -DLINUX \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', \
+ '', \
+ bb.utils.contains('DISTRO_FEATURES', 'wayland', \
+ '-DEGL_API_FB -DEGL_API_WL', \
+ '-DEGL_API_FB', d), d)} \
+"
-PACKAGECONFIG_append_mx6q = " egl glesv2"
-PACKAGECONFIG_append_mx6dl = " egl glesv2"
-PACKAGECONFIG_append_mx6sx = " egl glesv2"
+PACKAGECONFIG_append_imxgpu3d = " egl glesv2"