aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc
AgeCommit message (Collapse)AuthorFilesLines
2018-10-07dtc-145: Fix compile failure with latest master on muslKhem Raj2-2/+59
This issue is primarily seen when building the target recipe on musl the fix is a partial backport from upstream to get over the hump Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
2018-10-06Revert "dtc-145: Limit BSP specific recipes on relevant SOCs"Max Krummenacher1-1/+0
This creates a regression. dtc-145-native is needed. The native.bbclass sets MACHINEOVERRIDES to "" which then makes buiding a recipe which DEPENDS on dtc-145-native fail. This reverts commit 16c528880f20c68731e645775d31c7445c95a8db for recipes-kernel/dtc/dtc-145_git.bb. compare with output of 'bitbake -e dtc-145-native | # set /build/krm/oe-core_master/build/../layers/openembedded-core/meta/classes/native.bbclass:113 | # "" | # pre-expansion value: | # "" | MACHINEOVERRIDES="" Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
2018-09-28recipes: Limit BSP specific recipes on relevant SOCsKhem Raj1-0/+1
This helps in using meta-freescale with other BSP layers in same projects, which is common usecase Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com> Cc: Zhenhua Luo <zhenhua.luo@nxp.com> Cc: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
2018-07-30dtc-145: Deploy renamed binary only and add new classMax Krummenacher1-0/+6
dtc-145-native is used by older U-Boot recipes. U-Boot only depends on the native dtc binary. So, to not clash with files from the regular dtc native build do only install the dtc binary renamed to dtc-145. Also, create a new class to handle with dtc-145 dependency. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
2018-06-26dtc: Add recipe for version 1.4.5Fabio Berton2-0/+29
We need dtc version 1.4.5 to build u-boot-imx 2017.03, current version 1.4.6 raise a lot of errors and can't build older U-Boot version. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>