aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.11.0.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.11.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.11.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.11.0.bb
new file mode 100644
index 00000000..43a2b459
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.11.0.bb
@@ -0,0 +1,19 @@
+# Copyright 2020-2021 NXP
+
+DESCRIPTION = "Kernel loadable module for ISP"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/vvcam/LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44"
+
+SRCBRANCH = "imx_5.4.70_2.3.2"
+ISP_KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/isp-vvcam.git;protocol=https"
+
+SRC_URI = " \
+ ${ISP_KERNEL_SRC};branch=${SRCBRANCH} \
+"
+SRCREV = "6cbf264313b4859c985c8d66bae19b522996de6c"
+
+S = "${WORKDIR}/git/vvcam/v4l2"
+
+inherit module
+
+COMPATIBLE_MACHINE = "(imx|use-nxp-bsp)"